Masaüstü yeniden başlatmadan sonra parlaklık ayarlarını hatırlamıyor

55

Makinemi her açtığımda parlaklık Gnome'da% 100'e geri döner. Keşke son ayarı saklardı. Zaten var mı?

    
sordu Decio Lira 08.09.2010 03:53

11 cevap

11

Bunun enerji seçeneklerinde yapılandırılabilir olması, parlaklığı istenen düzeye getirmesi ve her zaman kullanılmasının gerekmesi. Bir dizüstü bilgisayar kullanıyorsanız, pil modunun seviyesini de ayarlamanız gerekir ...

Gnome'un LCD panel parlaklığı ile ilgili bazı sorunları olduğunu buldum. Pil modunda çalışırsam ve parlaklığı manuel olarak belirli bir seviyeye ayarlar ve dizüstü bilgisayarı 10 saniye boyunca gözetimsiz bırakırsam, geri aldığımda ön ayarlı parlaklığa geri döner. Aynı şey A / C modundayken daha uzun sürdüğünde aynı şey daha kolay fark edilmeden gider. Tüm bu ayarların bir yerde saklanması ve geri yüklenmesi gerektiğine inanıyorum - en azından A / C modu için.

DÜZENLEME: gnome3 için bu işe yaramıyor (en azından benim için).

    
verilen cevap levesque 08.09.2010 04:06
21

/etc/rc.local dosyası şöyle görünmelidir:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
echo 0 > /sys/class/backlight/acpi_video0/brightness
exit 0

Per @zerdo: Benim dell studio 1558'de parlaklık ayarı /sys/class/backlight/intel_backlight/brightness dizininde saklanır. Bilgisayarınız acpi_video0 klasörünü kullanmıyorsa yolu değiştirin.

Ayrıca, @Nick başına: Bu okuduğunuz tek cevap buysa, echo 0 cinsinden 0'ın varsayılan parlaklık ayarınız olacağını unutmayın. Bunu ben kurmuştum ve bu beni uzun süredir çıldırtıyordu: ne zaman başlattığımı her defasında en düşük parlaklık ayarına getirecekti. Benimki maksimum parlaklıktan başlamayı tercih ederim, bu yüzden onun yerine echo 10 kullandım. Donanımınız parlaklık ölçeğinde değişebilir.

    
verilen cevap dolhow 17.10.2011 15:59
13

Bu işlev, arka ışık kontrolü, bios ve çekirdek sürümünüze bağlıdır.

Bu dört şeyi deneyin.

Çekirdek (önyükleme) seçenekleri

Önyüklerken, grup ekranında düzenlemek için e tuşuna basın. Kernel satırına nomodeset acpi_backlight=vendor ekleyin. Bazı donanımlar farklı seçeneklerle çalışabilir.

Intel - nomodeset acpi_backlight=intel Acer - acpi_backlight=acer_acpi veya hatta acpi_osi=Linux acpi_backlight=legacy .

Gördüğünüz gibi, google ayarlarınızı aramanız gerekebilir.

quiet splash nomodeset acpi_backlight=vendor

Çalışıyorsa, /etc/default/grub değerini düzenleyin ve bu seçenekleri varsayılan seçeneklere ekleyin.

# command line
sudo -e /etc/default/grub

# graphical
gksu gedit /etc/default/grub

"GRUB_CMDLINE_LINUX_DEFAULT" satırını düzenleyin. Böylece

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

Düzenlemenizi kaydedin, grubunu güncelleyin

sudo update-grub

Komut satırı

Bu işe yaramazsa, parlaklığı manuel olarak ayarlamayı deneyebilirsiniz.

Not: Yol, donanım / çekirdek sürümüne göre değişebilir, /proc/acpi/video0 ... olabilir, parlaklık ayarını bulmak için / proc / acpi dizinine göz atmanız ve aşağıdaki komutları buna göre ayarlamanız gerekebilir.

cat /proc/acpi/video/VGA/LCD/brightness

Bu komutun çıkışı donanım ile bir miktar değişir, 1 - & gt; 10, 1 -> 12, 1 -> 100 ??? Bir değer seçin ve ayarlayın (donanımınızın değerini seçin).

sudo echo 80 > /proc/acpi/video/VGA/LCD/brightness

Eğer çalışırsa, /etc/rc.local

dosyasına ekleyin.
# command line
sudo -e /etc/rc.local

# graphical
gksu gedit /etc/rc.local

Yukarıdaki ayarlarınızı "çıkış 0" ı ekleyin

echo 80 > /proc/acpi/video/VGA/LCD/brightness

xbacklight

Ayrıca xbacklight

deneyebilirsiniz
sudo apt-get install xbacklight

Sonra komut satırı ile ayar yapın

# For 80 % brightness
xbacklight -set 80

Yine, bunu /etc/rc.local

dosyasına ekleyin.
# command line
sudo -e /etc/rc.local

# graphical
gksu gedit /etc/rc.local

"Çıkış 0" ın üstüne ekleyin

xbacklight -set 80

setpci

Parlaklığınızı setpci

ile ayarlamayı deneyebilirsiniz.

Genel sözdizimi

sudo setpci -s <address> f4.B=your_setting

pci bus adresinizi

ile tanımlarsınız
sudo lspci | grep VGA

Örnek

00:02.0 VGA compatible controller: Cirrus Logic GD 5446

setpci -s 00:02.0 F4.B=80

Ayarınızı yanlış yaparsanız, büyük olasılıkla ekranınızı kaybedersiniz ve yeniden başlatmanız gerekir. Bu bir donanım ayarı olduğundan, gerçekten donanımınızı tanımlamanız ve öncelikle ayarları araştırmanız gerekir.

Örnekler

Intel - İşte

Toshiba - İşte

Acer extensa - İşte

Ubuntu man page setpci

    
verilen cevap Panther 21.12.2011 23:54
7

İşte bunun için hızlı bir çözüm: -

Bu komutu, terminalde bu komutu yazarak test etmeyi deneyin

echo 0 > /sys/class/backlight/acpi_video0/brightness

Parlaklık minimum değerse, doğru anladınız!

Yazarak /etc/rc.local dosyasını düzenleyin

sudo -H gedit /etc/rc.local    

terminalde

Başlangıçta # ekleyerek exit 0 'yi şöyle göründüğü şekilde yorumlayın: -

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#exit 0

bu gerekli, aksi takdirde işe yaramaz!

Bundan sonra şu satırı dosyaya ekleyin

echo 0 > /sys/class/backlight/acpi_video0/brightness

öyle görünüyor ki: -

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#exit 0
echo 0 > /sys/class/backlight/acpi_video0/brightness

gerekli parlaklık değeriyle 0'ı değiştirin (0 ile 10 arasında değişir)

dosyayı kaydedin ve çıkın.

Değişiklikleri görmek için yeniden başlatın.

Not: - acpi_video0 değerini farklı bir cihazınız varsa (çoğunlukla acpi_video0 ) cihaz kodunuzla değiştirmeniz gerekebilir. Çoğu kullanıcının buna ihtiyacı yoktur.

    
verilen cevap vasishath 16.10.2011 11:44
4

11.10'da ekran parlaklığını ayarlamak için, "Sistem Ayarları" na erişmeniz gerekir:

  1. Ekranınızın sağ üst köşesindeki araç çubuğunda doğrudan kullanıcı adınızın sağına sağ tıklayın.

  2. "Sistem Ayarları" nı seçin.

  3. "Ekran" ı seçin.

  4. Ekran parlaklığını ayarlamak için kaydırıcıyı farenizle sürükleyin.

Ubuntu ayarlarınızı hatırlamıyorsa, bir uygulama kullanabilir veya GNOME için geçici çözümü kullanmanız gerekebilir: Parlaklık ayarı Ubuntu 11.10’da kaydedilmedi

    
verilen cevap KaitlinM 24.10.2011 04:39
3

İşte, Ubuntu forumunda thaelim'i bulduğum, kredi ve teşekkürlerimi sunan harika bir çalışma Nasıl etkin bir ekran parlaklık yönetimi elde edilir? Birlik / Gnome Kabuğu komut dosyasını yalnızca betiğin başındaki perimetreleri düzenleyin ve işiniz bittiğinde ev klasörünüze kaydedin. Her komut, brightmanager.py dosyasının tamamını indirerek

Bunlar, istediğiniz ayarlara geçmek için değişken perimetrelerdir, zira her zaman boşta zaman aşımı olmaksızın 20'yi sevdiğimi görebilirsiniz.

IDLE_DIM_TIME = 0
IDLE_DIM_AC = False
IDLE_DIM_BATTERY = False
IDLE_BRIGHT = 20
BRIGHT_BATTERY = 20
BRIGHT_AC = 20

Kaydedildikten sonra bir terminal açın ve

girin
chmod +x brightmanager.py

Ardından başlangıç ​​uygulamalarını kısa çizgi ile açın, ekle düğmesini tıklayın, başlangıç ​​uygulamanızı adlandırın ve komutunuzu şu şekilde girin:

python /home/david/brightmanager.py

"david" i, ev klasörlerinizin ismiyle değiştirdikten sonra bir açıklama ekleyip ekle, oturumu kapat ve tekrar aç ve tamamladığınızda pil, AC ve boşta parlaklık ayarlarına sahipsiniz.

Her kullanıcı için bunu yapmak isteyeceksiniz ve her kullanıcının betiğin başlangıcında kendi komut dizilerini kendi klasörlerinde kendi istenen ayarları ile olması gerekir.

    
verilen cevap dginsd 11.11.2012 18:24
1

"Sistem Ayarları" nın "Ekran" seçeneği tamam çalışıyor ve /sys/class/backlight/acpi_video0/brightness 'de bu seçenek de buna göre değişiyor, ancak sorun gerçek parlaklıkla hiçbir şey olmuyor.

Sorunun çözümünü buldum:

"Cihaz" bölümünüzün altındaki bir sonraki seçeneği /etc/X11/xorg.conf 'de ekleyin ve yeniden başlatın:

Option "RegistryDwords" "EnableBrightnessControl=1"

Bu, NVIDIA kartım için çalıştı (Toshiba Satellite L745-SP4142CL'de Ubuntu 11.10 x64)

    
verilen cevap Jorge 04.04.2012 18:44
1
  • nVidia'yı kullanmanız gerekiyorsa, yalnızca giriş sayfasını açın ve "NVIDIA X sunucu ayarı" yazın.
  • Ardından, X Ekranı O altında "X Sunucusu Renk Düzeltme" ye tıklayın.
  • Parlaklık seviyesini azaltın.
  • Süre dolmadan "Mevcut değişiklikleri onayla" yı tıklayın.
  • Değişikliği kaydetmek için Çık'ı seçin.

Aşağıdaki özellikler ile çalıştım:

  • Toshiba Satellite L745
  • Intel Core i3
  • CUDA ile NVidia GeForce
  • RAM 6 GB
verilen cevap Chuaka 13.04.2012 20:32
1

Bunun hakkında bir hata raporu var gibi görünüyor:

İşte

Benim için işe yaradı:

echo 0 > /sys/class/backlight/acpi_video0/brightness

/etc/rc.local içinde.

Ya da başkalarının önerdiği gibi,

echo 5 > /sys/class/backlight/*/brightness

işe yarayabilir.

    
verilen cevap duli 29.12.2011 23:06
0

Webupd8'de bir geçici çözüm buldum: Parlaklığı sıfırlamaya ( Ubuntu'da yeniden başlatmada çok düşük bir değer veya maksimum)

  
  1. Yapmanız gereken ilk şey, hangi ACPI arayüzünün (acpi_video) parlaklığı kontrol ettiğini bulmaktır. Bu, hangi acpi_video'un yüklendiğini görmek için Xorg günlük dosyasına bakarak yapılabilir. Bunu komut satırı ile yapmak için aşağıdaki komutu kullanın:

    grep acpi_video /var/log/Xorg.0.log
    
         

    Yukarıdaki komut, buna benzer bir çıktı göstermelidir:

    [     7.385] (--) intel(0): Found backlight control interface
    acpi_videoX (type 'firmware') for output LVDS1
    
         

    acpi_videoX 'si acpi_video0 veya acpi_video1 . Bu, parlaklığı kontrol eden acpi_video modülüdür, bu yüzden sonraki adımlar için hatırlayın.

         

    Yukarıdaki komut herhangi bir çıktı göstermiyorsa ve intel_backlight altında /sys/class/backlight/ adlı bir klasörünüz varsa, sonraki adımlarda ACPI arabirimi olarak intel_backlight kullanın.

  2.   
  3. Sonra, dizüstü bilgisayarınızın parlaklığını, Ubuntu'nun başladıktan sonra kullanmasını istediğiniz düzeye ayarlayın.

  4.   
  5. Şimdi, 2. adımda ayarladığınız gerçek parlaklık değerini elde etmek zorundayız. Bunu yapmak için aşağıdaki komutu çalıştırın:

    cat /sys/class/backlight/acpi_videoX/brightness
    
         

    Burada acpi_videoX , dizüstü bilgisayarınızın parlaklığını kontrol eden ve 1. adımda bulduğunuz ACPI arabirimidir.

         

    Bir sonraki adım için bu değeri unutmayın.

  6.   
  7. Sonraki adım, fixbrightness.conf dizininizde /etc/init/ adlı bir dosya (kök olarak) oluşturmaktır, örneğin:

    gksu gedit /etc/init/fixbrightness.conf
    
         

    Ve bu dosyada şunu yapıştır:

    description "Sets brightness after graphics device is loaded"
    
    start on graphics-device-added
    
    task
    
    exec /bin/echo BRIGHTNESS_VALUE > /sys/class/backlight/acpi_videoX/brightness
    
         

    Burada yapmanız gereken

         
    • BRIGHTNESS_VALUE değerini 3. adımda aldığınız parlaklık değeriyle değiştirin

    •   
    • acpi_videoX 'yı, dizüstü bilgisayarınızın parlaklığını kontrol eden ACPI Arabirimi ile değiştirin; 1. adımda bulduğunuzda.

    •   

    Ardından dosyayı kaydedin.

  8.   
  9. Yeniden başlat / yeniden başlatıldıktan sonra yeniden başlatma ve düşük veya maksimum parlaklık sorunu düzeltilmelidir.

  10.   
    
verilen cevap evergreen 05.12.2014 17:20
-1

Çalıştır

echo 2 > /sys/class/backlight/acpi_video0/brightness

    
verilen cevap Suresh Kumar Pakalapati 20.10.2011 15:20

Etiketlerdeki diğer soruları oku