Ubuntu'daki .deb paketleri ile sorun 16.04

53
  

Bu hata artık yukarı akış yönünde . Bir güncelleme yapıldı. Hala yükleyemiyorsanız, tam olarak güncellediğinizden emin olun ve bilgisayarınızı yeniden başlatın.

İndirilen DEB paketlerini yüklemeye çalışıyorum. Her seferinde böyle bir uyarı görüyorum:

Yüklemeyi tıklamak sadece yükler ve hiçbir şey değişmez.

Bu, denediğim ve yüklediğim tüm paketleri gösterir. Bir paketi nasıl kurabilirim?

    
sordu Shahram Shinshaawh 22.04.2016 17:18

8 cevap

57

Bu, # 1573026 hatasıdır. "Bu beni de etkiler" seçeneğini tıkladığınızdan emin olun.

  

Bu hata şu anda yukarı akışta düzeltildi . Umarım bir güncelleme derhal verilecektir.

Çözümler neler?

GDebi paket yöneticisini, mevcut yazılım merkezinde veya sudo apt-get install gdebi kullanarak kullanabilirsiniz. komut satırından.

Ardından paketi yüklemek için GDebi'yi açın ve Dosya - & gt; Açın ve indirilen DEB dosyasına gidin.

Paketi açmak için biraz zaman alabilir - benim için yaklaşık 10 saniye sürdü.

Sonra her şeyin yolunda olduğunu kontrol edin ve yükleyin.

Tamamlanacak ve program yüklenecek.

Ya da komut satırını kullanabiliriz. % Co_de% bir DEB dosyasından yüklenemiyor olsa da, apt-get dosyasının tamamı dosyayı indirir ve apt-get öğesini çağırır. Bu görevleri kendimiz yapabiliriz.

Bir terminal açın ve indirme konumumuza dpkg ile gidin.

Ve komutu çalıştırın:

sudo dpkg -i FileName.deb

DosyaAdı dosyasının adıyla değiştirilmesi.

Son olarak şunu çalıştırın:

sudo apt-get install -f

Bu "her şeyi" düzeltir - tüm bağımlılıkları vb. giderir.

    
verilen cevap Stan 22.04.2016 18:01
11

El ile yüklediğiniz tüm .deb dosyaları, sistemin yazılımdaki lisansı doğrulayamadığı 'üçüncü taraf' konumlarından geldiği kabul edilir. Google Chrome yükleyici, Ubuntu depolarını değil, üçüncü taraf olan Google’dan kaynaklanır. Buradaki uyarı iletisi, bunu belirtir, ancak lisans koşullarını doğrulayamadığından, aynı zamanda olabilir özgür olmamak Google Chrome kullanmaya devam etmek için hala uygun.

Gördüğünüz mesaj, 'geçerli' bir yüklemenin ya da güvenilebilecek bir şey olduğundan emin olmak istediğinizde bir uyarı işlevi görür ve yazılımın Ubuntu depolarından kaynaklanmadığına dair bir uyarıdır. ; Ayrıca, buradaki bazı yazılımların olabileceği nin ücretsiz olmadığını ve üzerinde başka lisans kısıtlamaları olabileceğini de belirtir.

Bu yazılımı aklınızdan çıkarmadan önce, yazılımın Ubuntu bakımının yapılmadığı veya özgür olmayan lisans kısıtlamalarına sahip olabileceğini akılda tutmanız gereken başka şeyler olabileceğini size bildirmenin bir ya da daha az yolu vardır. co_de% dosyası.

Bu bir hata değil - bir uyarı mesajı. Yine de "Yükle" düğmesini tıklayıp Google Chrome tarayıcısını veya .deb dosyalarından boş zamanlarınızda başka bir şey yükleyebilirsiniz. (bağımlılık sorunları varsa - bu farklı ve ilgisiz bir konu).

Yeni yazılım merkezi çalışmıyorsa, bu bir hatadır - bu mesaj bununla ilgili değil. /

Gidelim ve manuel yükleme yöntemini kullanalım.

Terminalde manuel olarak yükleyebiliriz. % Co_de% 'yi kullanıcının .deb klasörüne kaydettiğinizi varsayalım. "PACKAGE" dosyasını burada gerçek dosya adıyla değiştirin.

sudo dpkg -i ~/Downloads/PACKAGE.deb
sudo apt-get install -f

Ayrıca, .deb 'sini, yalnızca çözülmesi gereken bağımlılıkların olması durumunda Downloads sonra çalıştırmalısınız. apt-get install -f , bağımlılık sorunlarını belirleyebilir, ancak dpkg -i değeri yoktur.

    
verilen cevap Thomas Ward 22.04.2016 17:32
1

Google Chrome apt-get install -f söz konusu olduğunda benim için bağımlılıkları yalnızca apt-get update sonra değiştirdiler:

sudo apt-get update
sudo dpkg -i google-chrome-stable-...-amd64.deb
sudo apt-get install -f
    
verilen cevap V G 16.09.2016 13:43
0

Aynı sorunu yaşıyorum ve bu benim problemimi çözdü
 1. sunucu havuzunu ana alana değiştir
 2. güncelleme sistemi
 3. yeniden başlat

    
verilen cevap Osama AbuSitta 01.09.2016 23:31
0

Bu problemi yaşadım. Ubuntu'nun 32-bit sürümünü yanlışlıkla yükledim ama 64-bitlik bir tane olduğunu düşündüm. Bu yüzden 64-bit .deb paketlerini kurmaya çalıştığımda bu sorunu yakaladım ama 32-bit .deb paketlerini kurmaya çalıştığımda bunlar sorunsuz bir şekilde kuruldu.

    
verilen cevap frostmann 13.10.2016 21:58
0

İlk önce bir terminali açmanız gerekir ( Ctrl + Alt + T )

Sonra şunu yazın:

sudo apt install gdebi-core

Şifreyi girin, ardından uygulamayı Ubuntu Yazılım Merkezi ile tekrar açmayı deneyin.

Benim için çalışıyor

    
verilen cevap NgocThach Pham 29.03.2017 08:51
0

Ctrl + Alt + T tuşlarına basarak terminali açın. Tip:

sudo apt-get -f install

Enter tuşuna basın, şifrenizi girin.

Hata olmadan çalışırsa, şunu yazın:

sudo apt install gdebi-core

Enter tuşuna basın. Bundan sonra, Yazılım Merkezini kullanabildim, açtım ve tüm OS Güncellemelerini yükledim.

    
verilen cevap user766999 02.12.2017 17:14
-1

Herhangi bir bağımlılığı indirebilmesini sağlayan en basit yoldur. Bazen gdebi GUI'sini indirmez (bu sorunu kendimle karşılaştım).

Aşağıdaki komutu kullanarak gdebi çekirdeğini yükleyin

sudo apt install gdebi-core

Ardından, .deb paketinizin açık olduğu klasörde cd yapın. Örneğin:

cd ~/debs/

Daha sonra, aşağıdaki komutu kullanarak application.again dosyanızı yüklemek için bu komutu kullanın: -

sudo gdebi google-chrome-table_51.0.2704.63-1_amd64.deb

Gerekirse bağımlılıkları indirmeli ve uygulamanızı başarıyla yükleyecektir.

    
verilen cevap Cruelplatypus67 28.05.2016 10:09

Etiketlerdeki diğer soruları oku