14.04'te Qt5 için geliştirme paketi nedir

62

Masaüstü bilgisayarımda bir Qt5 örneği oluşturmak istiyorum. % Co_de% ve qt5-default yükledim, ancak yine de bu hatayı alıyorum:

Project ERROR: Unknown module(s) in QT: quick qml

Derleme için hangi paket kurulmalıdır? Qt4 zamanında sadece qtdeclarative5-dev

idi     
sordu marmistrz 08.08.2014 10:06

4 cevap

56

Yüklemeniz gerekiyor

qtdeclarative5-dev
    
verilen cevap AlexGreg 08.08.2014 10:20
59

Ubuntu'da bulunan tüm Qt5 geliştirme paketlerinin listesi .

Qt module           dev package                         lib package
-------------------------------------------------------------------------
bluetooth           qtconnectivity5-dev                 libqt5bluetooth5
concurrent          qtbase5-dev                         libqt5concurrent5
connectivity        qtmobility-dev                      libqtconnectivity1
contacts            qtmobility-dev                      libqt5contacts5
core                qtbase5-dev                         libqt5core5a
dbus                qtbase5-dev                         libqt5dbus5
designer            qttools5-dev                        libqt5designer5
designercomponents  qttools5-dev                        libqt5designercomponents5
feedback            qtmobility-dev                      libqt5feedback5
gallery             qtmobility-dev                      libqtgallery1
gui                 qtbase5-dev                         libqt5gui5
help                qttools5-dev                        libqt5help5
location            qtmobility-dev                      libqt5location5
multimedia          qtmultimedia5-dev                   libqt5multimedia5
multimediakit       qtmobility-dev                      libqtmultimediakit1
network             qtbase5-dev                         libqt5network5
nfc                 qtconnectivity5-dev                 libqt5nfc5
opengl              libqt5opengl5-dev                   libqt5opengl5
organizer           qtmobility-dev                      libqt5organizer5
positioning         qtpositioning5-dev                  libqt5positioning5
printsupport        qtbase5-dev                         libqt5printsupport5
publishsubscribe    qtmobility-dev                      libqt5publishsubscribe5
qml                 qtdeclarative5-dev                  libqt5qml5
quick               qtdeclarative5-dev                  libqt5quick5
quickparticles      qtdeclarative5-dev                  libqt5quickparticles5
quicktest           qtdeclarative5-dev                  libqt5quicktest5
quickwidgets        qtdeclarative5-dev                  libqt5quickwidgets5
script              qtscript5-dev                       libqt5script5
scripttools         qtscript5-dev                       libqt5scripttools5
sensors             qtmobility-dev, libqt5sensors5-dev  libqt5sensors5
serialport          libqt5serialport5-dev               libqt5serialport5
serviceframework    qtmobility-dev                      libqt5serviceframework5
sql                 qtbase5-dev                         libqt5sql5
svg                 libqt5svg5-dev                      libqt5svg5
systeminfo          qtmobility-dev                      libqt5systeminfo5
test                qtbase5-dev                         libqt5test5
uitools             qttools5-dev                        ?
versit              qtmobility-dev                      libqtversit1
webchannel          ?                                   ?
webkit              libqt5webkit5-dev                   libqt5webkit5
websockets          libqt5websockets5-dev               libqt5websockets5
widgets             qtbase5-dev                         libqt5widgets5
x11extras           libqt5x11extras5-dev                libqt5x11extras5
xml                 qtbase5-dev                         libqt5xml5
xmlpatterns         libqt5xmlpatterns5-dev              libqt5xmlpatterns5

    
verilen cevap gossen 24.01.2015 16:03
37

Başlığın cevabı şöyledir:

sudo apt-get install qtbase5-dev

Özel probleminiz için yukarıdaki cevaplar doğrudur.

    
verilen cevap Henk van der Laak 20.11.2014 02:04
0
sudo apt-get install qtdeclarative5-dev qml-module-qtquick-controls

Yüklemeyi :: :: / p> ile doğrulayın.

qtchooser -print-env

Çıktı aşağıdaki gibi olabilir (Ubuntu sürümünüz için mevcut paketlere bağlı olarak):

QT_SELECT="default"
QTTOOLDIR="/usr/lib/x86_64-linux-gnu/qt5/bin"
QTLIBDIR="/usr/lib/x86_64-linux-gnu"

Referans buradaki .

    
verilen cevap parasrish 27.06.2018 12:30

Etiketlerdeki diğer soruları oku