Chrome Java Eklentisini Yükleme

51

Şu anda birkaç saatliğine Chrome için Java eklentisini yüklemeye çalışıyorum ve daha fazla deneyimi olan kullanıcılara sormanın zamanının geldiğini anladım. Çalışmayı başaramıyorum. Şu anki Java versiyonum 64-bit OpenJDK 1.6.0_24. IcedTea eklentisini boşuna yüklemeyi denedim. Şu an Ubuntu 12.04 64-bit yüklü.

Chrome'da java etkinleştirildiyse test yapmayı denediğimde, Java uygulaması olan herhangi bir web sitesi yüklenmedi (eklentiyi devre dışı bıraktığımda, yüklediler, ancak uygulamayı değil).

Buradaki talimatları izledim: İşte

Bu komut dosyasını oluşturup çalıştırdığın söyleniyor:

JAVA_HOME=/usr/lib/jvm/jdk1.7.0
MOZILLA_HOME=~/.mozilla
mkdir $MOZILLA_HOME/plugins
ln -s $JAVA_HOME/jre/lib/i386/libnpjp2.so $MOZILLA_HOME/plugins

Not: JAVA_HOME değerini, JDK yüklemenizi doğru bir şekilde gösterecek şekilde değiştirmeniz gerekebilir. 64 bit kullanıcıların son satırı şu şekilde değiştirmesi gerekir:

ln -s $JAVA_HOME/jre/lib/amd64/libnpjp2.so $MOZILLA_HOME/plugins

Fakat bu işe yaramadı.

Sadece Firefox'ta test ediyorum ve çalışıyor. Chrome için hala hiçbir şey yok

    
sordu kyleskool 25.06.2012 18:07

7 cevap

56

Chrome için alternatif yükleme Java, ayrıca icedtea'yı da yükleyebilir:

 sudo apt-get install icedtea-7-plugin

Ardından icedtea'yı krom eklenti klasörüne bağlayın

cd /usr/lib/chromium-browser/plugins

ve bağlantı

sudo ln -s /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so 
    
verilen cevap gare 07.11.2012 22:55
12

Java eklentisi artık Chrome'da çalışmıyor (sürüm 45+). Buradan :

  

Chrome tarafından NPAPI desteği

     

Web tarayıcıları için Java eklentisi, çapraz platform eklentisine dayanır   NPAPI, uzun süredir var olan ve şu anda destekleniyor   tüm büyük web tarayıcıları tarafından. Eylül 2013’te açıklanan Google’ın planladığı plan   NPAPI desteğini Chrome'dan "2014'ün sonuna kadar" kaldırarak   Silverlight, Java, Facebook Video ve   diğer benzer NPAPI tabanlı eklentiler. Son zamanlarda Google,   planlar ve şimdi NPAPI'yı tamamen kaldırmayı planladıklarını belirtiyorlar   2015 . Bu tarihlerin daha da uzatılıp uzatılmayacağı belli olmadığından, Java kullanıcılarının Chrome'a ​​alternatifleri dikkate almasını şiddetle öneririz.   en kısa zamanda . Bunun yerine Firefox, Internet Explorer ve   Uzun vadeli seçenekler olarak Safari.

    
verilen cevap Michele 26.02.2015 13:24
8

Birçok cevap şimdi tarihlenmektedir. 14.04 Ubuntu kurulumum için çalışmadılar. Chrome örneğim için /opt/google/chrome yüklenmiştir. Yani eklenti klasörünün orada oluşturulması gerekiyordu.

Güncellenmiş talimatları İşte adresinde bulabilirsiniz.

  1. Sahip değilseniz, eklenti adı verilen bir dizin oluşturun. Tür: mkdir -p / opt / google / chrome / plugins

  2. Sembolik bağlantıyı yapmadan önce Google chrome plugin dizinine gidin. Tür: cd / opt / google / chrome / plugins

  3. Sembolik bir bağlantı oluşturun. Tür: ln -s /usr/local/java/jre1.7.0/lib/amd64/libnpjp2.so

  4. Tarayıcınızı yeniden başlatın ve Java'yı test edin

Chrome 34+ kullanıcıları için güncelle

Lütfen bkz. Chromium'daki java eklentisi . Temelde IcedTea eklentisi, Google varsayılan olarak NPAPI arayüzünü devre dışı bıraktığı için Chome ile artık çalışmamaktadır.

Sonunda benim çözümüm, firefox'a geri dönmek olacak.

    
verilen cevap kervin 14.07.2014 17:36
6

Son zamanlarda aynı hatayı gördüm. % Co_de% dosyanıza bakarsanız, muhtemelen şunları görürsünüz:

/build/buildd/icedtea-web-1.2/build/../plugin/icedteanp/IcedTeaNPPlugin.cc:2072: thread 0x7f08d1365470: Error: Invalid plugin function table.

Hata raporu Eklenti Chrome’da yüklenemedi . Önerilen bir güncelleme ~/.xsession-errors paketi için yayımlandı ve çalışmaya onaylandı. Bu, tüm kullanıcılar için birkaç gün içinde inmelidir.

Bu arada, diğerlerinin önerdiği gibi farklı bir tarayıcı kullanabilirsiniz, Firefox burada çalışır.

    
verilen cevap Lekensteyn 18.08.2012 10:48
6

Bulduğum en iyi çözüm, (bu önerilerin hiçbiri benim için işe yaramadı), aşağıdaki gibidir: İlk olarak Icedtead eklentisini şu şekilde yükleyin:

  • 1) sudo apt-get install icedtea-7-plugin

Ardından, chrome tarayıcınızda şu adrese gidin:

  • 2) chrome- & gt; Ayarlar & gt; Gelişmiş Ayarları Göster - & gt; Gizlilik ve ardından tıklayın İçerik Ayarları - & gt; Eklentiler ve ardından Bireysel Eklentiyi Devre Dışı Bırak
  • 'ı tıklayın.
  • 3) " IceTea-Web Eklentisi " ve " Java (TM) " öğelerini devre dışı bırakın
  • 4) Tarayıcıyı yeniden başlatın.
  • 5) chrome- & gt; Ayarlar & gt; Gelişmiş Ayarları Göster - & gt; Gizlilik ve ardından tıklayın İçerik Ayarları - & gt; Eklentiler ve ardından Bireysel Eklentiyi Devre Dışı Bırak
  • 'ı tıklayın.
  • 6) yalnızca " IceTea-Web Eklentisi " ni etkinleştir
  • 7) Keyfini çıkarın!
verilen cevap Amir 06.04.2013 20:46
3

Aynı sorunu yaşıyorum. Bir süre etrafta kazandıktan sonra, Chrome'un 64 bit Java desteği olmayan 32 bitlik bir uygulama olduğunu öğrendim. ( İlgili bir konu Oracle tarafından burada açıklanmıştır. )

Bu, sisteminize 32 bit Java sürümü (temelde Java 6) yüklemeniz gerektiği anlamına gelir. Şahsen ben girişimden vazgeçtim, ama bu eski soruya bazı yardımlarda bulunabilir.

    
verilen cevap Yubin Kim 25.05.2013 10:29
0

Benim durumumda, Chromium uygulamayı başlatmıyordu, mesaj yok, uygulamanın olduğu yerde sadece gri bir kutu görünüyordu, bu yüzden bir şeyler yapıyordu, ancak yeterli değil. OP'ye benzeyen sesler. Tarayıcı olmayan java uygulamaları önceden sistemimde çalışıyordu.

Yüklü durumu belirlemek için bir yerde which javac kullanılması önerilir. Bu, hiçbir terminal çıkışı oluşturdu. Bu yüzden javac'ı aramayı denedim ve java için yükleyici paketlerinin listesini aldım. Yani sanırım bir çeşit sınırlı kurulum yaptım, ne olduğu ya da neden olduğu hakkında bir fikrim yok.

sudo apt-get install openjdk-7-jdk uygulandı ve daha sonra başka şeyleri denerken daha önce devre dışı bıraktığım icedtea Chromium eklentisini (Ayarlar | Gelişmiş Ayarlar | Gizlilik | İçerik ayarları | Ayrı ayrı eklentileri devre dışı bırak) yeniden etkinleştirildi. Listede başka bir Java eklentisi yok.

Ta-da! Java uygulamaları artık Chrome'da çalışıyor. Önceden Java'yı nasıl yüklediğimi veya ne zaman yüklediğimi hatırlayamıyorum, ama muhtemelen 'en az dirençli' bir yaklaşımdı, bu yüzden bazılarının da aynı sistem durumuna sahip olabileceğinden şüpheleniyorum.

    
verilen cevap Justin Maxwell 05.06.2013 12:18

Etiketlerdeki diğer soruları oku