En yeni GIMP sürümünü nasıl edinebilirim?

58

GIMP'nin yeni bir versiyonunun mevcut olduğunu anlıyorum, ancak bunu yapmanın tek yolunun kaynaktan derlenmesidir: P

Bunu elde etmenin başka bir yolu var mı, yoksa derlemem gerekirse, bunu terminal aracılığıyla veya daha iyi yapabilirim; GUI?

    
sordu JASAXBY 08.05.2012 22:03

10 cevap

98

Ubuntu 12.04 LTS, 14.04 LTS, 16.04 LTS, 17.10, 18.04 LTS

Bunu Terminal aracılığıyla yapabilirsiniz:

  1. GIMP'yi Kaldır

    sudo apt-get autoremove gimp gimp-plugin-registry
    
  2. Aşağıdaki PPA'yı ekleyin

    sudo add-apt-repository ppa:otto-kesselgulasch/gimp
    sudo apt-get update
    
  3. En son GIMP'yi tekrar yükleyin

    sudo apt-get install gimp
    
verilen cevap Bastian Gruber 08.05.2012 22:08
11

12.04'ten önceki Ubuntu sürümleri

Şu anda, Gimp 2.8'i 12.04'ün altındaki herhangi bir sürüme yüklemek için bir yöntem yoktur.

mümkün mü? ...

Aşağıdaki nedenlerden dolayı olası değil:

Gimp'in en son sürümlerinin bağımlılıkları, 12.04'ün altındaki herhangi bir sürümde bulamayacağınız en son temel kitaplıkları gerektirir. Böylece, derlenmesini sağlamak için kod bölümlerini yeniden derlemeniz ve yeniden yazmanız gerekecektir. 12.04'ten ne kadar uzakta olursanız, gereken değişiklik o kadar büyük olur.

Gimp paketinin bir bakıcısı (ppa: matthaeus123 / mrw-gimp-svn), açıklamanın en son Gnome-3 PPA ve diğer bazı kütüphaneleri test etme . Bunların ikisi de gnome-2 ortamlarına (11.10'un altına) yüklenmeyecek. Gimp'in 12.04 versiyonu için bağımlılık listelerine baktığımızda bunlar da 11.10'da mevcut değil.

12.04'ün altındaki sürümler için bir PPA'da mevcut olacak mı? Muhtemelen bunun için bunu yapmak isteyen girişimci bir geliştirici olmadığı sürece olası değil olduğunu söylemek güvenli olacaktır.

O zamana kadar, UbuntuForums kaynağından nasıl derleneceğine dair ilginç bir konuya sahiptir.

Böylece - kesinlikle Gimp 2.8'i istiyorsanız - 12.04 + 'dan fazla masaüstü ortamından birini kurmaya bakın.

    
verilen cevap fossfreedom 05.05.2012 14:27
6

Kalıcı GIMP 2.8 kullanılabilirliği Fortunatelly ayrıca gimp eklenti kayıt (web eklentisi için ünlü kaydetme ile) kolay kurulum yaptı.

İşte ile:

GIMP 2.8 kararlı yükleme

Eski bir GIMP sürümünden yükseltme yapıyorsanız lütfen bağlantıyı ziyaret edin ve 'dist-upgrade' komutuna dikkat edin İşte (ayrıca GIMP 2.6.x'e geri dönmek isterseniz)

Mevcut sistem kurulumunuzda GIMP'yi ilk kez kuruyorsanız:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

GIMP 2.8 yüklemesi için GIMP Eklenti Kaydı

İşte

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp-plugin-registry
    
verilen cevap Bucic 30.05.2012 21:00
6

Ubuntu 14.04 ve üstü

GIMP'nin en son kararlı sürümünü Ubuntu'nun şu anda desteklenen tüm sürümlerinde hızlı bir paket olarak kurmak için terminali açın ve şunu yazın:

sudo snap install gimp

Notlar

  1. En son kararlı sürümden (örneğin GIMP 2.10.0 yerine GIMP 2.10.2) aşamalı olarak daha yeni bir sürüme ihtiyacınız varsa, bunu edge kanalından yükleyin.

    sudo snap install gimp --edge
    
  2. Harici ortama tam erişim için GIMP'ye ihtiyacınız varsa (USB flash sürücü, SD / MicroSD kart, ek takılı sabit sürücü vb.), aşağıdaki komutu çalıştırın:

    sudo snap connect gimp:removable-media
    
$ sudo snap connect gimp:removable-media
$ snap interfaces gimp
Slot              Plug
:desktop          brave,gimp,notepad-plus-plus,notepadqq,simplenote
:desktop-legacy   brave,gimp,notepad-plus-plus,notepadqq
:gsettings        brave,gimp,notepadqq,simplenote
:home             brave,gimp,notepad-plus-plus,notepadqq,simplenote
:opengl           brave,gimp,notepad-plus-plus,notepadqq,notes,simplenote,sudoku-game
:removable-media  gimp,notepad-plus-plus,notepadqq
:unity7           brave,gimp,notepadqq,notes,simplenote,sudoku-game
:wayland          brave,gimp,notepad-plus-plus,simplenote
:x11              gimp,notepad-plus-plus,notepadqq,simplenote,sudoku-game
-                 gimp:cups-control

    
verilen cevap karel 15.06.2018 14:16
3

Bu projeyi destekleyelim.

İşte

gimp2.9’u indirebiliyorum ve Gimp’in daha önceki bir sürümü tarafından reddedilen bir dosyayı açabiliyorum. Ve hala ubuntu 10.04 Lucid kullanıyorum.

Bu gerçekten Linux sistemlerinde bozuk bir durumdur çünkü en yeni uygulamaları çalıştırmak için tüm sisteminizi yükseltmeniz gerekir. Umarım bu yakında çözülür ve umarım yukarıdaki gibi projeleri destekliyoruz.

Ubuntu 10.04 ile mutluyum ve burada çok sayıda konfigürasyonum var ve geliştirme dosyalarım da 2016 yılına kadar lol yükseltmek zorunda kalabiliyor!

    
verilen cevap nbjayme 24.02.2014 07:38
2

GIMP 2.8'i Lucid 10.04.4'te almak için şuna bakın:

İşte

    
verilen cevap AC2 18.05.2012 09:47
1

Ubuntu 16.10

apt install gimp

Şimdi oldukça kolay.

    
verilen cevap Azuaron 07.04.2017 14:59
0

Ubuntu 16.10

Ubuntu 16.10, kolayca aşağıdaki komutla terminalden yükleyebilirsiniz:

sudo apt install gimp

Mevcut bir gimp yüklemesini yükseltmek için, terminalde aşağıdaki komutu çalıştırın:

sudo apt update && apt upgrade -y

Eğer terminalde aşağıdaki komutu çalıştırın, gimp kaldırmak ancak (örneğin, başka bir zaman yeniden planlıyorsanız) ayarları korumak için

isterseniz:

sudo apt remove gimp

gimp kaldırıp ayarlarını kaldırmak istiyorsanız, terminalde aşağıdaki komutu çalıştırın:

sudo apt purge gimp

    
verilen cevap Ken 07.04.2017 16:25
0

Haziran 2018'den itibaren, Gimp 2.10’u istiyorsanız cevap verin

Ubuntu 17.10 ve üstü için:

PPA'yı ekleyin: İşte ve çok sayıda paket güncellenecek / yüklenecek, özellikle Gimp'in kendisinden ve gimp-eklenti-kayıt defteri, bu şekilde kurulması çok daha kolay olan çeşitli yararlı eklentiler (resynthesize, vs ...) içeren. Eğer siz 17.04'ünüz varsa, bu PPA size Gimp 2.8.22 verecektir.

Eski sürümler için (en önemlisi 16.04):

  • Resmi yol: bir uygulama olan "flatpak" sürümünü, kendi bağımsız kitaplık kümeleridir. Talimatlar Gimp indirme sayfası ’nda kullanılabilir.
  • Resmi olmayan yol: bir "AppImage" kurarsınız (uygulamayı "kapsaymak" için başka bir yol). Bunun için birkaç geliştirici var, bir sürüm burada .

Her iki yöntemin de kısıtlamaları vardır, özellikle de favori derlenmiş eklentilerinizi eklemek zor olabilir (script-fu ve python eklentileri genellikle OK'dir).

    
verilen cevap xenoid 16.06.2018 09:53
-1

bu PPA benim için çalışıyor ve size en son sürümü sunacak Not: Bu, sürümün geliştirilmeye devam etmesini de sağlayabilir

sudo add-apt-repository ppa:otto-kesselgulasch/gimp-edge

ayrıca, buradaki diğer adımlar için de gidebilirsiniz

sudo apt-get update
sudo apt-get install gimp -y

bu, gimp'in geçerli sürümünü görüntüler

sudo gimp --version
    
verilen cevap Mohammed Omer 10.05.2018 07:55

Etiketlerdeki diğer soruları oku

Ubuntu GNOME 17.04: wi-fi çalışmıyor - mac adresi değişmeye devam ediyor? ___ answer580210 ___

Bilgisayarınızı bir Ubuntu live-CD veya live-USB'de önyükleyin

sonra ikinci seçeneği izleyin: Ubuntu'da Önyükleme-Onarma 'nu şu bağlantıdan yükleyin:

İşte

    
___ answer495993 ___

Aşağıdakileri deneyin ...

%pre%

Kalıcı bir düzeltme için başarıyla önyükleme yaptıktan sonra aşağıdakileri çalıştırın:

%pre%

%code% , açılış sürücünüzdür.

    
___ Ustuntu bölümü silindikten sonra qstnhdr ___ GRUB kurtarma sorunu! [çift] ___ qstntxt ___

Ubuntu bölümümü sildikten sonra bilgisayarımı yeniden başlattım ve yalnızca bir ileti alıyorum:

%pre%

%code% listeleri

komutu %pre%

Onları tek tek kontrol ediyorum:

%pre%

Fakat doğru bölümü bulamıyorum.

    
___ answer643528 ___

Aynı problemim vardı. GRUB'u kaldırdım. Sadece başka bir PC'den Windows 8 veya 10'u indirin. ISO'yu Rufus ile USB'ye yazdırın. USB'den önyükleme yapın, Sorun Giderme 'yi, ardından Komut İstemi ' ni tıklayın ve şunu yazın:

%pre%

Windows Ubuntu'nun GRUB'u olmadan normal şekilde başlayacaktır. Ubuntu'yu yeniden yükleyebilirsiniz.

    
___ answer793972 ___

Ben de aynısını yaptım. Ubuntu bölümü silindi. BIOS'a girebiliyorum.

Ubuntu için önyüklenebilir bir USB'niz varsa, BIOS'a girin ve önyükleme sırasında önce USB'yi seçin. Tekrar başlat. Sonra Ubuntu'yu tekrar yükleyin. Ve bu sefer SAFELY'yi silebilirsiniz.

    
___