Skype ve VLC sesler sizzle / bozuk / kötü

51

skype bildirim seslerinin boyutlandırılmış ve Skype'ta oturum açmak için kötü ses . Ama sadece giriş, bildirim değil, aynı zamanda biriyle konuşurken de. Skype ve / veya bu çözümdeki çözümlerin çoğunu yeniden kurmak için çözümü denedim, örn. karıştırıcıyı, ses ayarlarını kontrol etmek ve alsa-hda-dkms (sistem yeniden başlatması dahil) yüklemek. Ubuntu 12.04 (AMD 64) 'de skype (ve skype 4.0'a yükseltildikten sonra bile) yüklendikten sonra hiç ses gelmedi. SoundTroubleshooting Procedure 'un ilk adımını takip ettim ve en azından şu anda ses geliyor:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-'uname -r' libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-'uname -r' libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG 'cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print }' | tr '\n' ',' | sed 's:,$::g'' 'whoami'

Titreşim sesi bazen ortadan kaybolur, örn. Kaydedilen parçanın tekrar oynatılmasından sonra Echo-Testcall'da. Ve müzik ritminde oynamasına izin verip skype başlatırsam sesin iyi olduğunu fark ettim. Bu yüzden zayıf bir çözümüm var, ama bu yolsuzluk olmadan çalışacağına sevinirim.

Oynattığımda VLC'de, duraklamadan sonra yeniden başlat, aynı titreme sesine sahip olmalıyım.

İstendiği gibi: Ses kartım, bir Lenovo Thinkpad Edge 525'teki Advanced Micro Devices (AMD) Hudson Azalia denetleyici (rev01), alt sistem Lenovo Device 21ea (sysinfo'ya göre) adı verilen bir "AMD Yüksek Tanımlı Ses Aygıtı" dır.

    
sordu Filbuntu 30.06.2012 09:03

9 cevap

92

Bu sadece Skype ile ilgili bir sorun değil, bunun bir sorun olduğunu tahmin ediyorum, bunu tahmin et, PulseAudio.

Çözüm? Gerçekten var.

PulseAudio'nun Glitch Free Audio'sunun devre dışı bırakılması benim için çatırtıyı çözmüş görünüyor (Ubuntu 12.10 Beta 2'de dayanılmaz bir hale geldi)

Bunu yapmak için, favori metin düzenleyicinizde /etc/pulse/default.pa dosyasını düzenleyin.

Aşağıdaki satırı arayın:

load-module module-hal-detect

ve sonuna " tsched=0 " değerini ekleyin:

load-module module-hal-detect tsched=0

Darbeyi yeniden başlatın (ya da sadece sisteminizi yeniden başlatın) ve çığlık atılmalıdır.

Glitch Free Audio özelliğini devre dışı bırakarak yan etkilerin ne olduğundan emin değilsiniz, ancak henüz bulamadım.

GÜNCELLEME: % Co_de% ile bir satırınız yoksa, aşağıdaki satırı arayın:

load-module module-udev-detect  

ve sonuna " load-module module-hal-detect " değerini ekleyin:

load-module module-udev-detect tsched=0

Darbeyi yeniden başlatın (ya da sadece sisteminizi yeniden başlatın) ve çığlık atılmalıdır.

    
verilen cevap Robert Ian Hawdon 16.10.2012 16:28
3

Sorunlara neden olan darbenin olduğunu düşünüyorsanız, sizin için daha kolay bir düzeltme olabilir. Kötü sesin nasıl düzeltileceği hakkında adım adım yol tarifi içeren bir makale yayınladım Ubuntu'da . Bu şarap için bir çözümdür, ancak bu bir pulseaudio konfigürasyon dosyasının bir modifikasyonu olduğundan, diğer benzer problemlere uygulanabilir.

    
verilen cevap Seven_Six_Two 11.07.2012 16:28
3

Robert tarafından sunulan çözüm benim için çalıştı. Ben 12.10 ubuntu kadar yükseltilmiş ve yeni skype 4.0 yükseltme kullanılamaz ses (cızırtılı ve bozuk) vardı. Yukarıdaki talimatlara göre düzenleme yapmak ve aşağıdaki satırı eklemek için: /etc/pulse/default.pa dosyasındaki load-module module-hal-detect tsched = 0 sorunu mükemmel bir şekilde çözdü.

Farkında olmak için 12.10'a yükseltmek, Soundblaster kartımın varsayılan olarak tanınmamasını sağladı. Bazı nedenlerden dolayı artık NVIDIA grafik kartımın varsayılan ses kartı olduğunu düşünmek varsayılan. Skype başlangıçta HAYIR ses yapacaktır.
Bu, Ubuntu forumlarında yayınlanan talimatın 27 Temmuz 2008'de billesboelle tarafından takip edilmesiyle düzeltilebilir. Burada kapsayıcılık için tekrarlanmıştır: Aşağıdaki gibi tam bir ses koruma rehberinden ayarları denedikten sonra, varsayılan olarak pci kartını seçmek için Ubuntu'yu alamıyorum:
Görünüşe göre indeks = 0 işlevi bana yardım etmek istemiyor. Belki de benim makine registres 2 ses sürücüleri aynı adı taşıyan gerçeği nedeniyle? cat /proc/asound/modules bu yanıtı veriyor:

0 snd_hda_intel  
1 snd_hda_intel  
2 snd_cmipci  

Bana yardım edebilmek için herhangi bir fikir veya görmek istediğiniz bir şey. Btw, bahsetmeyi unuttum. İndeks seçeneğini denerseniz, pci canım aplay -l ve cat / proc / asound / modules dizinlerinden kaldırılır.

Varsayılan ses kartlarını yapılandırma / anahtarlamadan birden fazla ses kartını durdurma Not: Bu bölüm, her bir ses kartını doğru şekilde yüklediğinizi varsayar.

Bir kabukta yazın

    cat /proc/asound/modules 

Bu, şu anda sahip olduğunuz ses kartlarının adını ve dizinini verecektir. İsim not edin ve hangisinin varsayılan kart olmasını istediğinize karar verin.

Şimdi yazın

    sudo nano /etc/modprobe.d/alsa-base

Dosyanın sonuna aşağıdakileri ekleyin (A, B ve C modül adlarıyla 3 kartınız olduğunu varsayarak bunları CAB düzeninde bulundurmak istediğinizi varsayalım).

options snd-C index=0  
options snd-A index=1  
options snd-B index=2
    
verilen cevap Coop999 23.11.2012 16:39
2

Ubuntu 16.04 için düzeltme

sudo vim /etc/pulse/daemon.conf default-fragment-size-msec değerini buldum, benim durumumda devre dışı bırakıldı, bu yüzden satırın ; 'sini satırın başlangıcında kaldırın, bu yüzden default-fragment-size-msec = 5 gibi görünmelidir (varsayılan değer 25 ' yi 5 olarak değiştirdim). Daha sonra sadece pulseaudio --kill hizmetini öldür ve ubuntu, herhangi bir sebepten ötürü olmasaydı, sistemi yeniden başlatırsa, pulseaudio'u yeniden başlatır.

Artık skype sesini çok net duyabiliyorum.

    
verilen cevap Viktor 26.02.2018 22:31
1

Archlinux'ta aynı sorun vardı. Pulseaudio buna neden oldu. Pulseaudio'dan kurtulmak, Skype'ta benim için temiz bir ses verdi. Ana hat Ubuntu gibi Gnome tabanlı dağıtımlar için gsm dahil gnome malzemelerinin çoğuna bağımlı olduğu için pulseaudio'u çıkarmak imkansızdır, ancak kubuntu, xubuntu ve lubuntu'da bu aslında başlangıçta pulseaudio ile gelmediği için işe yarayabilir ve gnome bloatware, ve eğer kuruluysa, büyük ihtimalle gnome veya kütüphanelerine bağlı olan başka bir paketin bağımlılığı oldu.

    
verilen cevap ccpizza 30.06.2012 10:00
1

Sadece toshiba p875-s7200 üzerinde 12.04 ubuntu gelen pulseaudio kaldırıldı ve güzel skype sabit! ses boktan harikaya gitti :) not: Bu dizüstü bilgisayarda ses almak için alsa-hda-dkms yüklemem gerekiyordu

    
verilen cevap dave 13.07.2012 01:31
0

Bu benim için çalıştı, ubuntu 12.10 / 64, mb asus m4a785tdv-evo amd64 (ses VIA VT1708S)

/etc/pulse/default.pa ( sudo pico /etc/pulse/default.pa ) düzenlenmiş

load-module module-hal-detect bulunamıyor

Bu yüzden, load-module module-udev-detect satırını düzenledim, böylece:

load-module module-udev-detect tsched=0

değişiklikleri kaydedip sistemi yeniden başlattı. Şimdi Skype iyi görünüyor. Şimdiye kadar, bazen konuşma sırasında ayarlanmış / durdurulmuş (bazen web tarayıcısını kapatırken sabitlenmiş) çatırdama / yankı / gürültü ile Skype kullanırken sorunlar yaşadım, ancak bazen konuşmayı büyük ölçüde tehlikeye atmaya devam ediyordu. Skype, görünüşe göre benim için ses sorunları olan tek durumdu.

    
verilen cevap user119773 08.01.2013 18:55
0

Şimdiye kadar gönderilen çözümlerin hiçbiri 14.04 tarihinde benim için çalışmamıştı, ancak Tercihler -> Ses -> Çıktısında ses modülünü alsa 'ye ayarlamak benim için vlc'de ayarladı.

    
verilen cevap Chiel ten Brinke 28.03.2015 19:50
-4

İnternet bağlantınızı kontrol etmelisiniz (hız testi için İşte ).

Ayrıca, RyhthmBox'tan sonra çalıştığı için sürücüleri (ses kartı için) güncellemeyi de deneyebilirsiniz.

Ayrıca, bilgisayarınızda ne tür bir ses kartınızın olduğunu bize bildirmeniz halinde diğer yanıtlayıcılara da yardımcı olabilir.

    
verilen cevap Farid 30.06.2012 09:08

Etiketlerdeki diğer soruları oku