Adobe Flash player'ı nasıl yüklerim?

101

64 bit Ubuntu'da flash video izlerken önemli sorunlar yaşadım. Herkes platformda flash çalıştıran iyi bir yol biliyor mu?

    
sordu Steven Oxley 28.07.2010 21:27

20 cevap

81

11.04 ve öncesi için:

Ubuntu Yazılım Merkezi'nden mi yüklüyorsunuz?

  1. Uygulamalar -> Ubuntu Yazılım Merkezi'ne gidin.
  2. Canonical Partners'a tıklayın
  3. Adobe Flash Eklentisi 11’i tıklayın ve yüklemeyi tıklayın.

Not: Bu, 64 bit Ubuntu yüklememde kullandığım yöntemdir ve henüz beni başarısızlığa uğratmıştır.

    
verilen cevap Nathan Osman 28.07.2010 21:31
68

11.10 ve üstü için

Yazılım Merkezini Başlatıcı'dan başlatın ve flash

için arama yapın.

İki giriş bulunacaktır. Bunlardan ilki, Adobe'nin 32bit flash versiyonu etrafındaki sarıcıdır. İkincisi 64bit flash sürümüdür.

İkinci flaş girişini seçin - aşağıdaki resim görülürse, daha önce Canonical Partner Repository ürününü önceden etkinleştirmediniz.

Daha Fazla Bilgi 'yi tıklayın

... ve Canonical Partner Repository’i etkinleştirmek için Bu kaynağı kullan ’ı tıklayın

hata raporunun bu yanıtının sonuna bakın

Yükle

'yi tıklayın.

Yükle düğmesini tıklayın ve istendiğinde şifrenizi girin. Not - yazılımı yükleme iznine sahip olmalısınız.

Kurulum devam edecek:

Tamamlandığında - Firefox'u başlatın ve Flash Video'nuza göz atın. Sağ tıklayın ve Flash'ın en son sürümünün doğru şekilde yüklendiğini doğrulayın.

Not - değiştirilecek resimler - 64bit sürümü, Oneiric sürümünün son haftasında yalnızca son zamanlarda paketlendi - Şu anda bir sorun var:

  1. İşte

Arada - yukarıdaki resimlerde ilk "Multiverse" 32bit eklentisini kullanın veya adobe-flashplugin

kullanın.
sudo apt-get install adobe-flashplugin
    
verilen cevap fossfreedom 10.10.2011 00:52
31

Firefox için Adobe Flash Eklentisi nasıl yüklenir:

  1. bu sayfasına gidin ve diğer Linux için .tar.gz seçeneğini belirtin. Dosyayı indir.
  2. Eklentiyi tar.gz paketinden çıkarın ve dosyaları uygun konuma kopyalayın.
  3. Tar.gz eklentisini yerel olarak kaydedin ve dosyanın kaydedildiği konumu not edin.
  4. Terminali başlatın ve dizinleri dosyanın kaydedildiği konuma değiştirin.
  5. tar.gz dosyasını paketinden çıkarın. Paketini açtıktan sonra aşağıdakileri göreceksiniz:

    • libflashplayer.so
    • / usr
  6. Linux dağıtım ve Firefox sürümünüze bağlı olarak tarayıcı eklentileri dizininin yerini belirleyin. (Genellikle /usr/lib/mozilla/plugins/ 'dir)
    ubuntu 14.04 yolu: /usr/lib/firefox/browser/plugins

  7. libflashplayer.so 'yı uygun tarayıcı eklentileri dizinine kopyalayın. İstenen tipte:

    sudo cp libflashplayer.so <BrowserPluginsLocation>
    
  8. Flash Player Yerel Ayarlar yapılandırma dosyalarını / usr dizinine kopyalayın. İstenen tipte:

    sudo cp -r usr/* /usr
    
  9. Şimdi tarayıcınızı yeniden başlatın.

verilen cevap ignite 04.09.2012 18:36
21

Ubuntu'yu ilk kez kullandığınızı belirttiğinizden beri. ubuntu-restrictted-extras paketini yüklemenizi öneririm, bu adobe flash ve codec'ler ve MS fontları vb. gibi birçok yararlı içeriğe sahiptir.

Bunu birçok şekilde yapabilirsiniz.

yazılım merkezi: Bu bağlantıya tıklayın:

veya bir terminalde: sudo apt-get install ubuntu-restricted-extras

yazın

synaptic: ubuntu-restricted-extras paketini arayın, paketi sağ tıklayın ve install'u seçin, ardından işareti seçin. Uygula düğmesine tıkladıktan sonra hepsi yüklenecek.

    
verilen cevap Terry 02.04.2011 16:02
13

Bu sorun için basit bir çözüm var.

Firefox'unuzu açın ve Youtube adresine gidin. Herhangi bir videoya tıklayın. Kesinlikle flash player yüklü olmadığı için oynatılamaz. Ancak Firefox, sizi en üst install missing plug-in 'ye yükseltecektir. Sadece üzerine tıklayın ve prosedürü takip edin. Bundan sonra videonuz oynamaya başlar. En son Firefox tarayıcınızın kurulu olduğundan emin olun.

Veya bunu terminalinizde deneyin

sudo apt-get install flashplugin-installer
    
verilen cevap Kaktarua 04.09.2012 18:38
5

Firefox için Flash-Aid uzantımı alın. Sistem mimariniz için uygun sürümü indirip kurmaya ve ayrıca çakışan eklentileri kaldıracaktır. 64bit üzerindeyseniz, 64bit önizleme sürümünü de kurmanıza izin verir, bu da nspluginwrapper ile 32bit'den daha iyi sonuçlar verir.

BTW, ~ / .mozilla / plugins klasörüne herhangi bir şey kopyalayamazsanız, ~ / .mozilla klasörünün sahipliğini kontrol etmelisiniz. Orada bir şey kopyalamaya izin vermeli. Elbette, ana dizininizin dışındaki bir sistem klasörüne başvurursunuz, bu da root ayrıcalığı gerektirir.

    
verilen cevap lovinglinux 02.12.2010 13:40
4

Hangi tarayıcıyı kullandığınıza bağlıdır. Google Chrome (Chromium değil) varsayılan olarak Flash oynatıcısına sahiptir.

www.google.com/chrome adresine gidin ve Chrome'u indir'i tıklayın. 64-bit .deb'i seçin (32-bit'lik makineleri kullanarak bunu okuyan herkes 32 bit .deb'yi seçmelidir)

İndirildiğinde .deb dosyasına tıkladığınızda, Yazılım Merkezi'nde açılır. Şimdi yükle'yi tıklayın ve bittiğinde tarayıcıyı Uygulamalar - & gt; İnternet.

    
verilen cevap Mozart321 02.04.2011 22:00
2

Ubuntu Yazılım Merkezini kullanın (Uygulamalar menüsünde). Metin giriş alanında (arama kutusunun), "flash" araması yapabilir ve sonuçlar bir Adobe Flash eklentisini (Adobe logosuna dikkat edin) doldurabilir. Bunu seçin ve kaynağı kullanmak için talimatları izleyin.

    
verilen cevap Daniel T Chen 01.12.2010 20:14
2

Hangi "eklenti" dizininin kullanıldığını kontrol edin. Firefox'umun gerçekten okuduğunu ve daha sonra ln -s 'sini ortak bir noktaya işaret edecek şekilde bulduktan sonra, tüm eklenti dizinlerini tek bir kez geçirerek iyi bir saat geçirdim.

Günün sonunu yanlış yere bırakıyor olabilirsiniz.

Ayrıca firefox'u komut satırından başlat, hataları görebilirsiniz. Örnek bir x86 flash player'ı x64 tarayıcısında (os değil) ve tersini çalıştırıyor. Komut satırından ( %> firefox ) eklenti başlatma kayıt hatlarını görmelisiniz. (belki önce bunu deneyin: P)

Ayrıca /usr/lib/... öğesindeki her şey root'a aittir, bu yüzden sudo cp libflashplayer.so /usr/lib/firefox/plugin 'si .../firefox/plugin ' nin firefox eklenti dizininin konumuna işaret etmesi gerekir.

    
verilen cevap Dmitriy Likhten 01.12.2010 20:51
2

11.10'da 64 bit Flash için kesin düzeltme

11.10 sistemimde herhangi bir paketleyici olmadan 64 bit Flash'ı sabitledim. Yukarıda belirtilen çözümleri uygularsanız, 32 bit sürüm ve sarmalayıcılarla sonuçlanacaksınız.

Not: Bunun çoğu bir terminalde de yapılabilir, bu durumda Synaptic'i kurmanıza gerek yoktur. Dahası, sadece 5, 6 ve 8 numaralı adımları yürütmek yeterlidir, ancak bunu henüz test etmemiştim.

  1. Synaptic'i Yükle (Yazılım Merkezi, ihtiyacınız olan paketi, ana öğelerde değil, teknik öğelerin içinde değil, yüklendikten sonra bile göstermez)
  2. Synaptic'i başlatın ve 'flash' için arama yapın
  3. Yüklü duruma göre sırala
  4. Flash ile ilgili tüm paketleri kaldırın (flashplugin-downloader gibi: i386, flashplugin-installer, ndiswrapper-common vs.). Hiçbir şey listelenmemişse, muhtemelen hiç Flash yüklü değil. Bu durumda, sadece bir sonraki adıma geçin.
  5. Canonical iş ortağı deposunu etkinleştirin (bunun nasıl yapılacağına ilişkin yukarıdaki iletilere bakın)
  6. Paket listesini güncelleyin (bunu yapmak için Yazılım Merkezi'ne güvenmeyin, bazen bunu yapmaz)
  7. 'Yeniden Yükle'yi tıklatarak
  8. Tekrar 'flash' araması yap
  9. 'adobe-flashplugin' paketini yükleyin. Listede değilse, paket listelerinin güncellenmesiyle ilgili bir sorun oluştu. Synapic'ten çıkıp tekrar başlatmayı ve ardından 'Yeniden Yükle'yi tıklayın.

Ekstra bir paket, 'adobe-flash-properties-gtk' otomatik olarak yüklenecek. Daha fazla bir şey yok.

Artık Firefox ve Chromium'da herhangi bir paketleyici ve diğer çöpler olmadan tam 64 bit Flash'a sahip olacaksınız. Yine de tarayıcınızın yeniden başlatılması gerekir. Hala çalışmıyorsa, yeniden başlatmayı deneyin (eski eklentiler için bazı sahte referanslar olabilir).

    
verilen cevap iGadget 12.11.2011 13:18
2
sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper
sudo apt-get install --reinstall adobe-flashplugin

Ref: İşte

    
verilen cevap Coc 20.11.2011 11:21
2

Yapmanız gereken şey şu: varsayılan olarak, Ubuntu sadece açık kaynak kodlu yazılımla birlikte gelir (bence durum böyle, bence).

Diğer şeyleri (Flash, Java, ve açık kaynak OLMAYAN MP3'leri kaydetme veya çalma desteği gibi) etkinleştirmek, Yazılım Merkezinize gitmek, menülere gitmek (maalesef şu anda Ubuntu'da değilim) ve size hangi menüyü söyleyemiyoruz) ve Yazılım Kaynaklarını arayın.

Tıklayın ve Ubuntu'ya sizin için ne yüklemesine izin verildiğini söyleyen bir pencereye götürüleceksiniz. Önünüzde beş farklı "evren" in bir listesi olmalıdır. Yapmanız gereken, şu anda etkin olmayan ikisini etkinleştirmektir.

Bundan sonra, depolarınızı yeniden yüklemek isteyip istemediğinizi soracaktır, ancak eğer değilse, komut satırına girip

yazın.
sudo apt-get update

ve bitirsin. Ardından, Yazılım Merkezi'nde veya komut satırında flaşı bulabilmeniz gerekir. Alternatif olarak, yukarıda bahsettiğim üç şeyi size veren ubuntu-sınırlı-extras paketini kurabilirsiniz.

İyi şanslar!

    
verilen cevap Noah 04.09.2012 18:14
2

13.10 64bit yüklememde Chrome'da çalışmaya başlamak için çabayı bulabildiğim kadar olası önerilerden geçtim. Hiçbir şey işe yaramadı. Sonunda Pepper Flash cevabı üzerine tökezledim.

Tam ve iyi yazılmış talimatlar vardır (bağlantı doğrudan)

ubuntuhandbook.org

Ayrıntıları depolamayı, apt'i güncellemeyi, Pepper'ı yüklemeyi ve chrome config'u değiştirmeyi detaylandırdılar. Talimatlarından farklı olarak yaptığım şey, / etc / chromium-browser dizinine geçmek ve komutu vermek oldu.

sudo gedit default

, gerekli .sh bilgisine ek olarak dosyaya bir yorum eklememi sağladı, böylece değiştirilmiş varsayılan dosyamın son çift satırları:

# enable Pepper Flash Player Plugin
. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Umarım bu çözüm bir süre için çalışacaktır.

    
verilen cevap zenpistolero 03.05.2014 01:58
2

Flash videolar, yeni bir Ubuntu 14.04 sürümünde, "iş ortağı" havuzundan adobe-flashplugin olsa bile, youtube'da siyah ekrana sahip olsa da ( HTML5'i kullanmak için ayarlama ), dailymotion, vs.. freshplayerplugin (görünüşe göre Chrome'un flash oynatıcısı için bir sarıcı) sorunu çözdü:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
    
verilen cevap Skippy le Grand Gourou 22.08.2015 09:33
1

durumda

sudo apt-get install flashplugin-nonfree

çalışmıyor (benim durumumda olduğu gibi nedenini bilmiyorum ...), Opera'yı tarayıcınız olarak denemek isteyebilirsiniz. Benim için çalışan tek kişi.

PS: Opera'yı bir tarayıcıya tanıtmak istemiyorum, bu sadece bir şekilde benim için çalışan tek çözümdü.

    
verilen cevap Remi Meier 14.08.2010 15:19
1

Firefox'ta flaş kullanan ancak Chromium'da olmayanlar için yeni bir çözüm buldum. Her tarayıcının kendi eklenti dizinine sahip olması gerçeğine dayanır:

  • / usr / lib / firefox-addons / plugins (Firefox için)
  • / usr / lib / chromium-browser / plugins (Chromium için)

Yani, yapman gereken tek şey, onları bir diğeriyle bağlantı kurarak onları tanımlamak. Muhtemelen, tüm eklentiler Firefox eklentileri dizinindedir, ancak aşağıdakileri sağlamaya değmez:

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

Tüm eklentilerin bulunduğu Firefox ise, bir sonraki işlemi yapın. Değilse, tersi yapın:

sudo rmdir /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

Son olarak, Chromium'u yeniden başlatın, böylece değişiklikler etkili olur.

Muhtemelen, Chromium / Firefox paket düzenleyicileri üzerinde hata ve basit çözüm hakkında uyarmak için bir hata raporu oluşturmak kötü bir fikir olmaz.

    
verilen cevap emi 16.08.2012 19:19
1

Bunu birilerine yardım etme umuduyla gönderiyorum. Neler olduğunu ve nasıl çözdüğümü söyleyeceğim.

AYAR:
    Bir WUBI kurulumundan 12.04 koşuyor.

SORUN:
    Ubuntu Yazılım Merkezi’nde flash anahtar kelimesini aradığımda, burada yayınlanan seçeneklerden hiçbiri, Mozilla’nın flash plugin ’si için ONE dışında görünüyordu. Yüklemeye çalışırken, bir bağımlılık hatası aldım.

Ubuntu Software Center'dan Ubuntu Restricted Extras aracılığıyla yükleme gerçekleştirildi, ancak bu yüklemenin flash eklenti bölümü bağımlılık hatası nedeniyle çalışmadı.

Aramaktan vazgeçin ve eklentiyi kurmak için bu komutu buldum

sudo apt-get install flashplugin-nonfree

ve terminalden koştum.

Bu çıktıyla aynı bağımlılık hatası:

Reading package lists... Done Building dependency tree        
Reading state information... Done Note, selecting 'flashplugin-installer' instead of 'flashplugin-nonfree' 
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:
The following packages have unmet dependencies:  
 flashplugin-installer : 
 Depends: libnspr4-0d but it is not going to be installed E: Unable to correct problems, you have held broken packages.

ÇÖZÜM:

Koştum

sudo apt-get install -f 

ve sonra

sudo apt-get update 

, bağımlılıkları çözmeye çalışan başka bir gönderiden buldum.

Sonra koştum

sudo apt-get install flashplugin-nonfree

ve flash eklentisi artık Chromium ve Firefox'ta çalışıyor.

    
verilen cevap Joel 02.10.2012 17:55
1

Nasıl kurulduğuna bağlı. tar.gz dosyası veya rpm veya başka bir yöntemle mi. Flaş almanın bir sürü yolu var.

Download link: https://get.adobe.com/flashplayer/

Installation instructions
-------------------------

Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy the files to the appropriate location.  
    o Save the plugin tar.gz locally and note the location the file was saved to.
    o Launch terminal and change directories to the location the file was saved to.
    o Unpack the tar.gz file.  Once unpacked you will see the following:
        + libflashplayer.so
        + /usr
    o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
    o Copy libflashplayer.so to the appropriate browser plugins directory.  At the prompt type:
        + cp libflashlayer.so <BrowserPluginsLocation>
    o Copy the Flash Player Local Settings configurations files to the /usr directory.  At the prompt type:
        + sudo cp -r usr/* /usr

Installing the plugin using RPM:
   o As root, enter in terminal:
          + # rpm -Uvh <rpm_package_file>
          + Click Enter key and follow prompts

Installing the standalone player:
   o Unpack the tar.gz file
   o To execute the standalone player,
          + Double-click, or 
          + Enter in terminal: ./flashplayer

Bonus:

Uninstallation instructions
---------------------------

Manual uninstallation (for users who installed the plugin via Install script):
   o Delete libflashplayer.so binary and flashplayer.xpt file in 
   directory /home/<user>/.mozilla/plugins/

RPM uninstallation:
   o As root, enter in terminal:
          + # rpm -e flash-plugin
          + Click Enter key and follow prompts
    
verilen cevap Revanth Kumar 02.05.2015 03:59
0

Geçen hafta bu konudaki birçok yanıtı kontrol ettim. Sonunda DOES'in çalıştığı bir çözümle bağlantı buldum:

İşte

Temel olarak, yanıt, tüm yazılım kaynaklarından kaldırıldığını ve eski bir sürümü indirip el ile yüklemeniz gerektiğidir

    
verilen cevap palbeda 12.04.2017 16:33
0
  

Linux artık Adobe Flash Player'ı mağazasında desteklemiyor. Bu nedenle, manuel olarak yapmanız gerekiyor.

  

Bu yalnızca Firefox'ta doğrulanmış olup, Chrome / Chromium'unuz varsa onu yüklemeniz gerekmez.

Ubuntu'da Adobe Flash Player'ın Manuel Kurulum prosedürü var, şu adımları izleyin: -

  1. bu bağlantıyı açın. Masaüstü ortamınıza göre otomatik olarak bir sürüm önerecektir.

  2. Aşağıdaki ekran görüntüsünde gösterildiği gibi .tar.gz for Linux seçeneğini belirtin.

  3. Şimdi İndirme Düğmesi 'ye tıklayın (Kolay erişim için sisteminizde İndirme olarak indirme yolunu seçin).

  4. Şimdi dosyayı Right clicking klasörüne ayıkla ve Extract Here seçeneğini belirle.

  5. Terminal CTRL+ALT+T 'ı açın ve aşağıdaki komutu tek tek kopyalayın

    5.1. % Co_de%

    5.2. cd ../ (ör.; paper96)

    5.3. cd your-pc-name (dosyayı Seçenek 3 'e yüklediğiniz klasör budur.

    5.4. cd Downloads (Dosya adınız farklı olabilir, sadece dosyanın adını kopyalayıp terminalde yapıştırın)

    5.5. cd flash_player_npapi_linux.x86_64 isabetli giriş yapın ve bunu yapın.

  6. Şimdi tarayıcınızı (Firefox) ve Terminali kapatın.

  7. Firefox'u yeniden başlatın ve şimdi tarayıcınızda Flash Player var. Doğrulamak için bu bağlantıyı ziyaret edin.

verilen cevap Pankaj Gautam 17.07.2017 09:52

Etiketlerdeki diğer soruları oku