Misafir oturumunu nasıl devre dışı bırakırım?

181

Misafir oturumunu Ubuntu 11.10 veya üstü sürümde nasıl devre dışı bırakırım? İnsanların, giriş yapmak için şifremi kullanmadan bilgisayarımı kullanmasını istemiyorum!

    
sordu Jeremy Bicha 22.09.2011 17:45

12 cevap

117

Güncelleme: 2016-Ağustos

Ubuntu 16.04 LTS (15.10 veya üstü) için

Şunlardan uyarlanmıştır: LightDM Ubuntu Wiki - Yapılandırma

  • Sistem tarafından sağlanan yapılandırma dosyaları /usr/share/lightdm/ 'si, kullanıcı tarafından düzenlenebilir olmak için tasarlanmadı . Bunun yerine kullanıcılar kullanmalıdır: /etc/lightdm/
  • LightDM'nin daha yeni sürümleri (Ubuntu 15.10 veya sonraki bir sürümü) [Seat:*] yerine [SeatDefaults] kullanır

Bunu (bir kez) terminalde çalıştır:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Geri al (Konuk seçeneğini geri yükle), oluşturulan dosyayı kaldırın :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Ubuntu 14.04 LTS için (15.04'e kadar)

Aşağıdakilerden uyarlanmıştır: Ubuntu Forumları - 14.04'te lightdm yapılandırma dosyaları konumu

Bunu (bir kez) terminalde çalıştır:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Artık, bir sonraki girişinizde oturum açma seçeneği olarak 'Misafir' olmayacaksınız.

Geri al (Konuk seçeneğini geri yükle), oluşturulan dosyayı kaldırın :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Ubuntu 12.04 LTS için (13.10'a kadar)

En basit yöntem.

Bunu (bir kez) terminalde çalıştır:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Artık, bir sonraki girişinizde oturum açma seçeneği olarak 'Misafir' olmayacaksınız.

  • Bu, allow-guest=false 'sini /etc/lightdm/lightdm.conf ' ye ekler.

  • 11.10 tarihinden itibaren çalışmalıdır (bu kullanım LightDM olduğundan).

Geri al (Konuk seçeneğini geri yükle):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
verilen cevap david6 28.07.2012 01:38
115
  

Ubuntu Masaüstü kullanıyorsanız yalnızca bu yöntemi kullanın. Xubuntu veya Lubuntu gibi başka bir lezzet kullanıyorsanız, lütfen bunun yerine bu yanıtı inceleyin.

Varsayılan LightDM'yi kullanıyorsanız, aşağıdaki gibi /etc/lightdm/lightdm.conf dosyasını düzenleyin:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

GDM kullanıyorsanız (önceki Ubuntu sürümlerinde bu varsayılan değer), gdm-guest-session 'u kaldırın.

Ubuntu 13.10 - 14.10 için, dosya /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

konumuna taşındı.

Ubuntu 14.10 veya üstü için, dosya taşındı % Co_de%

    
verilen cevap Jeremy Bicha 22.09.2011 17:48
24

Bunu terminalde yazın

gksu gedit /etc/lightdm/lightdm.conf

Aşağıdakileri göreceksiniz:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Son sonucun şöyle görünmesi için allow-guest=false 'yi sonuna kadar ekleyin:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Belgeyi kaydedin ve metin düzenleyiciden çıkın.

Terminalde, ekran yöneticisini yeniden başlatın. (Bu, grafik giriş oturumunu sona erdirecek, hemen içinde çalışan tüm programları bırakacaktır, bu yüzden işinizin - açık belgeler gibi - önce kaydedildiğinden emin olun!)

sudo restart lightdm

Grafik oturum açma oturumu sona erdiğinde, giriş ekranına döndüğünüzde, misafir hesabı devre dışı bırakıldığını fark edersiniz.

İşte bu - misafir hesabı artık kullanılamaz.

    
verilen cevap sarveshlad 25.10.2011 03:08
17

Bunu Ubuntu Tweak 'ı kullanarak yapabilirsiniz.

Yüklemek için şu komutları kullanın:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Yükledikten sonra Tweaks Giriş Ayarları 'na gidin ve "Misafir hesabı" nu kapatın.

    
verilen cevap Eliran Malka 21.10.2012 19:54
11

Çalıştır

gksudo gedit /etc/lightdm/lightdm.conf

Aşağıdaki satırı ekleyin

allow-guest=false

Ardından (bu, sizi grafik oturumunuzda çalışan herhangi bir programdan çıkarak hemen çıkış yapacaktır, böylece işinizi kaydedin):

sudo restart lightdm
    
verilen cevap LnxSlck 27.07.2012 18:42
4

Gelecekte bu seçeneği nasıl devre dışı bırakabilirim

Yeni güvenilir / 14.04 yüklememde aynı sorunla karşılaştım. Ayrıca benim için sürpriz lightdm.conf.d /etc/lightdm/ içindeki users.conf klasörünü bulamadım.

Araştırılması

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, işte buradasın. İçeride ne var?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Tamam, orada ne var?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Sonuç

50-${some-descriptive-name}.conf adlandırma şemasını ve yapılandırma anahtarlarını takip eden INI biçimine benzer bir yapılandırma dosyaları bulduk [SeatDefaults] . bölümü için.

Bu dosyalardan herhangi birini düzenleyemeyeceğiz , bunlar paket yöneticisi tarafından yönetilecek, ancak şimdi özel yapılandırma bitleri% 'si /etc .

Çözüm

Yukarıdaki ışık verildiğinde, bu lightdm ekran yöneticisi ve yapılandırma dosyaları yukarıdaki gibi görünür. Aşağıdaki çözüm işe yarayacak:

  1. Eksik dizinleri oluşturun:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Çalışarak özel bir yapılandırma dosyası ekleyin:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    ve aşağıdaki satırları yapıştırın:

    [SeatDefaults]
    allow-guest=false
    

    Sonra kaydedin ( Ctrl + O ) ve kapatın ( Ctrl + X ).

  3. Şimdi çıkış yapın ve sanal terminale geçin ( Ctrl + Alt + F1 ), sonra çalıştırın:

    $ sudo service lightdm restart
    

    Konuk oturumu seçeneği şimdi gitmiş olmalı. Bir şey düzgün çalışmıyorsa, varsayılan yapılandırmanın nerede saklandığını ve değiştirmediğinizi şimdi biliyorsunuz.

Daha fazla okuma

verilen cevap LiveWireBT 16.03.2014 03:32
3

Ubuntu 13.10 için

ekleyin
allow-guest=false

/etc/lightdm/lightdm.conf.d/10-ubuntu.conf dosyasına.

    
verilen cevap uahummer 20.10.2013 15:27
3

13.04 ve üstü

  1. Bu komutu bir terminalde çalıştır

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Makinenizi yeniden başlatın veya aşağıdaki komutla lightdm 'yi yeniden başlatın. (Bu işlem sizi anında kaydedecek, verilerinizi kaydedecektir)

    sudo restart lightdm
    

Görünüşe göre, 13.10'da çalışıyor (kendimi test edemiyorum, ama bir yorum var burada ).

13.04 kullanıyorum ve bunların hepsi allow-guest=false 'si /etc/lightdm/lightdm.conf ' ye ekler, ancak 13.10'da farklı olabilir.

Aslen david6 buradan: İşte

    
verilen cevap kiri 21.10.2013 09:33
2

Ubuntu-tweak yükleyin, tweak sekmesine gidin, misafir düğmesini kapatın ve yeniden başlatın. Bu kadar!

Terminali daha kolay bulabilir, ancak misafir hesabını açma gereği ortaya çıkarsa, bu sayfayı tekrar ziyaret etmek ve talimatları görmek (veya daha sonra geri almak) gerekir. Bu GUI olayının avantajı ... bir tanesi kolayca hatırlar.

    
verilen cevap tadatma 27.09.2012 19:33
2

allow-guest=true değerini 'false' olarak değiştir /etc/lightdm/lightdm.conf

Daha sonra terminaldeki hizmeti yeniden başlatabilir veya yeniden başlatabilirsiniz:

sudo restart lightdm

11.10'da standart olan lightdm değerini kullandığınızı varsayalım.

    
verilen cevap filescraps 21.10.2011 12:42
0

Aynı durumda, /etc/lightdm/lightdm.conf dosyası UBUNTU 13.10'da mevcut değil.

/etc/lightdm/lightdm.conf dosyasını bu satır allow-guest=false ve CRASH ile oluşturmaya çalışıyorum, sistem düzgün çalışmıyor, sadece konsol modu ...

/etc/lightdm/lightdm.conf.d/10-ubuntu.conf dosyasını düzenlemeye çalışıyorum ve düzgün çalışıyor.

Dosyayı düzenle

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

İhtiyacınız olan satırları girin

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

Ve sonuncusu, sisteminizi yeniden başlatın

sudo reboot

Sadece ligthgdm'yi yeniden başlatırsanız bu işlemin iyi çalıştığını düşünüyorum

sudo service lightdm restart
    
verilen cevap Foncu 23.10.2013 16:05
0

Terminali Aç

gksudo gedit /etc/lightdm/lightdm.conf

Aşağıdaki satırı ekleyin

allow-guest=false

Dosyayı kaydedin ve çıkın.

    
verilen cevap scouser73 21.10.2013 09:29

Etiketlerdeki diğer soruları oku