Wifi, 16.04 yükseltmesinden sonra askıya alındıktan sonra çalışmıyor

133

"Askıya alındıktan sonra çalışmıyor" ifadesinin bu sürümü 16.04 sürümüne yükseltildikten sonra geldi. Yükseltme bir Wicd applet (normal ağ simgesinin yanında Metacity Classic Gnome görev çubuğuna eklendi) içerir, ancak askıya aldıktan sonra işe yaramaz gibi görünüyor. % Co_de% bu sorunu çoğaltır. Wifi tekrar gitmek için tam bir yeniden başlatma gerektiriyor. Herhangi bir fikir neden?

    
sordu 147pm 23.04.2016 13:42

10 cevap

161

16.04, systemd üzerinde çalışıyor. Aşağıdakileri deneyin:

sudo systemctl restart network-manager.service

Eğer çalışırsa, otomatikleştirmek için bir komut dosyası oluşturabilirsiniz.

Bir terminal açın ve aşağıdakileri yazın:

sudo nano /etc/systemd/system/wifi-resume.service Şimdi betiği oraya sağ tıklatarak yapıştırın. CTRL + X ile çıkın ve kaydetmek için Y düğmesine basın. Şimdi etkinleştirmek için: sudo systemctl enable wifi-resume.service

Senaryo:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Bunun yardımcı olacağını umuyorum. Dizüstü bilgisayarımda çalışıyor.

    
verilen cevap Joakim Koed 23.04.2016 15:17
8

@ 147 pm Hiç bu işe yaramadı mı?

Ben Kubuntu 16.10 (KDE tabanlı, Gnome değil) ve bir HP ProBook dizüstü bilgisayarında olmama rağmen oldukça benzer bir sorun yaşadığımı buldum. Ve, kendimden farklı olarak, askıya alma / uyandıktan sonra ölen Wifi'm değil, Ethernet ağım. Yine de merak ettiklerini merak ediyorum.

KDE kapsamında sorun yaşamadığınızı da görüyorum. Ancak, çözümün pencere yöneticisi, masaüstü ortamı veya uygulamalara dayanmadığı için aşağıdaki çözümün Gnome'ın altında olmasına yardımcı olup olmadığını bilmek isterdim.

Öncelikle, ağ yöneticisi hizmetini yeniden başlatmayı onaylamak için ..

$ sudo systemctl restart network-manager.service

benim için çalışmadı.

Ancak, yanıtladığım bir yanıt buldum, buzhidao'nun soruları ve bilgileri askıya alındıktan sonra İnternet'e bağlanamıyorum ve GAD3R'nin yorumu.

Bilgilerini kullanarak, ilk olarak hangi ethernet donanımının ve sürücünün / modülünün çalıştığımı araştırdığımı ve sonra bu modülü kaldırarak ve yeniden yüklediğimi, işe yaradığını buldum (buzhidao için olmasa da):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Bunların ikincisi (ethernet) kullanmış olduğum şeydi ve ben buldum:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

'r8169' sürücüsünü yeniden kurdum:

$ sudo rmmod r8169 && sudo modprobe r8169

ve voila! Bu çalıştı. Ethernet bağlantım / bağlantım yeniden başlatılmadan canlandırıldı (askıya alındıktan / uyandıktan sonra).

(Aynı zamanda bir Realtek wifi cihazım yoktu, ama belki de niçin wifi'nin wake-from-askıda kaldıktan sonra çalışmaya devam ettiğini açıklayan bir Qualcomm Atheros (mod: ath9k)).

Diğer gönderi hakkındaki yorumumdan da görebileceğiniz gibi, problemin Buzhidao ve kendim: Realtek Semiconductor cihazları arasındaki ortak unsur olup olmadığını merak ettim. Farklı modüller kullanıyor olsalar da, bazı ortak kodları paylaşabilirler? Veya daha yeni bir çekirdek koduyla bir şekilde farklı bir şekilde muamele görülebilir mi?

Kendiniz Realtek tabanlı bir wifi cihazınız var mı? (yukarıdaki lspci'yi kullanarak)? Modülü (yukarıdaki rmod / modprobe) yeniden yükleyerek şansınız var mı?

Her neyse, karanlıkta sadece bir atış. Kendiniz için nihai bir cevap bulduysanız, lütfen bize bildirin! Thx.

    
verilen cevap androclus 16.03.2017 23:40
6

sudo erişimi olmadan bir ortamda çalışmaya başladıktan sonra NetworkManager'ı otomatik olarak yeniden başlatmak için /etc/pm/sleep.d (herhangi bir ad) dosyasında bir komut dosyası oluşturun, yürütülebilir biti chmod +x yoluyla ayarlayın ve aşağıdaki içeriği ekleyin:

case "" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Benim için service satırı çalıştı, ancak systemctl sizin için daha iyi olabilir.

Kaynak: İşte .

    
verilen cevap krlmlr 05.11.2016 08:50
2

Benim için rasgele gibi görünüyor, ancak bazen bağlı olduğumda ya da ağlamıyorsam eğer ağlar bağlantıyı keser. Bazen dizüstü bilgisayarımı uyku moduna sokmak onu tetikliyor gibi görünüyor, ancak her zaman değil.

Bunların bazı bileşimleri, genellikle yeniden başlatmadan yeniden başlıyor:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • % Co_de%
    • Sadece sudo service network-manager stop; sleep 5; sudo service network-manager start 'yi çağırmak asla benim için işe yaramıyor. Kapatılmadan önce başlatmayı deniyor gibi görünüyor, dolayısıyla restart ile stop arasında duraklama daha fazla şansım var.
  • Kullanıcı arayüzünde kablosuz bağlantıyı kapatın; birkaç saniye bekle; tekrar aç

Bunların hiçbiri tutarlı bir şekilde işe yaramıyor gibi gözüküyor, ancak önce başarılı olma sırasına göre onları sıraladım.

    
verilen cevap redbmk 20.12.2016 17:07
2

Ubuntu 16.04 üzerinde çalışma yöntemi:

Hizmeti oluştur: sudo nano /lib/systemd/system/wifi-resume.service

Hizmet, programı şu adresten arıyor:
/etc/init.d/network-manager

Kodu yapıştırın:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ardından hizmeti etkinleştirin:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Bu, symlinks'i / etc / systemd / system'in belirtilen [Install] dizinlerine yaratır ve servisi etkinleştirir

Daha sonra durumu şu şekilde kontrol edebilirsiniz: systemctl status wifi-resume.service

    
verilen cevap cryptoboy 23.01.2017 01:59
1

Ben bluetooth ile aynı sorunu vardı: Bluetooth faremi askıya aldıktan sonra işe yaramadı. Bu yüzden çözümü yukarıdan aldım:

sudo nano /etc/systemd/system/bluetooth-resume.service

yeni hizmeti etkinleştirildi

sudo systemctl enable bluetooth-resume.service

ve servisi düzenledik

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ayrıca düzenlemeye çalıştım ...

sudo nano /etc/bluetooth/main.conf

ve değiştirildi

AutoEnable=true

Ancak bu "özgeçmiş problemi" için çalışmadı ve yeni bluetooth cihazlarda hiç bir şekilde etkisiz değildi!

    
verilen cevap apos 31.08.2016 13:11
1

Ubuntu 16.04 ile dizüstü bilgisayar Dell Inspiron 15R'de de aynı sorun vardı. Benim için ikinci cevapta rapor edilen raporda çalıştı.

Komut dosyasını kurduktan sonra, üstteki sağdaki komutla askıya almayı denedim ve hatta sorunu gidermek için dudağı kapattım.

Sorunun davranışında dönüşümlü olduğunu söylemek zorundayım (yani, bazen betiği kurmadan önce çalıştı).

    
verilen cevap Alessandro D'lncal 18.01.2017 15:58
0

Benim için çözüm çalışmaktı

nmcli nm sleep false

bir terminalde

    
verilen cevap tigerjack89 08.04.2017 13:01
0

Askıya alındıktan sonra ev wifi'ime bağlanırken aynı sorunu yaşadım. Zaman zaman çalışacak ancak her zaman olmayacak olan diğer çeşitli cevapları denedim.

Sonunda, sürekli olarak kablosuz ağa bağlanmak için aşağıdaki düzeltmeler yapılabilir:

1) Bu dosyayı düzenle:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Bunu ekleyerek:

[device]
wifi.scan-rand-mac-address=no
    
verilen cevap Ray Vega 28.03.2018 08:09
0

Şimdi muhtemelen basit

sudo apt update
sudo apt upgrade

çalışmalı.

Güncellenmiş paketler arasındaki durumumda bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) vardı ve bu güncellemeden sonra wifi tekrar çalışıyor.

    
verilen cevap Daniel 05.08.2018 07:08

Etiketlerdeki diğer soruları oku