ssh'in “şifre” sorgusu neden ortaya çıkıyor?

87

ssh değerini denediğimde, şifre istemi çok uzun sürüyor (neredeyse iki dakika).

Bu neden oluyor?

    
sordu Neuquino 22.01.2013 21:55

8 cevap

135

Yanlış gidebilecek bazı şeyler var. Ssh'in yaptıklarının ayrıntılı bir izini yazdırmak ve nerede duraklattığını görmek için -vvv ekleyin.

Sorun, istemcide veya sunucuda olabilir.

Sunucuda yaygın bir sorun, ters DNS aramalarının zaman aşımına uğradığı bir istemciden bağlanıyor olmanızdır. (Bir “ters DNS araması”, istemci makinenin IP adresinden bir ana bilgisayar ismine geri dönmek anlamına gelir. Güvenlik için gerçekten yararlı değildir, ancak günlük girişlerinden gelen ihlal girişimlerini tanılamak için biraz yardımcı olabilir, ancak varsayılan yapılandırma bunu yine de yapar.) Ters DNS aramalarını kapatmak için UseDNS no - /etc/ssh/sshd_config değerini ekleyin (sunucuda kök olmanız gerekir; daha sonra SSH hizmetini yeniden başlatmayı unutmayın).

yanlış gidebilen başka bir şey GSSAPI kimlik doğrulaması zaman aşımı. Bunun ne olduğunu bilmiyorsanız, muhtemelen ona güvenmiyorsunuz demektir; GSSAPIAuthentication no satırına /etc/ssh/ssh_config veya ~/.ssh/config satırını ekleyerek (bu, istemci tarafındadır) kapatabilirsiniz.

    
verilen cevap Gilles 22.01.2013 22:15
12

Giriş sürecine zaman ayırın ve ne kadar süreceğini görün:

[[email protected] ~]# time ssh [email protected]
[email protected]'s password:
Last login: Fri Oct  4 07:55:03 2013 from 3.60.40.232

[[email protected] ~]# exit
logout
Connection to ISSLABNTL01 closed.

real    0m45.192s
user    0m0.003s
sys     0m0.005s

You have new mail in /var/spool/mail/root
[[email protected] ~]#

Yukarıya bakın, giriş yapmak için yaklaşık 45 saniye sürdü -------- ÇOK YAVAŞ

root olarak sshd_config dosyasını düzenledikten sonra UseDNS girişini aşağıdaki gibi değiştirin. Burada dosyayı düzenlemek yerine sed kullanıyordum.

[[email protected] ~]# grep -i dns /etc/ssh/sshd_config
#UseDNS yes

[[email protected] ~]# sed -i 's/#UseDNS yes/UseDNS no/g' /etc/ssh/sshd_config
[[email protected] ~]# grep -i dns /etc/ssh/sshd_config
UseDNS no

[[email protected] ~]# service sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd:                                             [  OK  ]
[[email protected] ~]# exit

Giriş sürecini zamanlayalım ve şimdi ne kadar süreceğini görelim.

[[email protected] ~]# time ssh [email protected]
[email protected]'s password:
Last login: Fri Oct  4 07:55:03 2013 from 3.60.40.232

[[email protected] ~]# exit
logout

Connection to ISSLABNTL01 closed.

real    0m6.192s
user    0m0.003s
sys     0m0.005s

You have new mail in /var/spool/mail/root
[[email protected] ~]#

Şimdi 6 saniye sürdü, şifreyi yazmam için gereken zaman.

    
verilen cevap Mamadou Lamine Diatta 04.10.2013 14:39
4

Ubuntu'nun kurulumundan yanlış gelen bir şey.

Düzeltmek için /etc/nsswitch.conf adresinde bu satırı değiştirmeniz gerekir:

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

Ve bunun için değiştirin:

hosts:          files dns
    
verilen cevap Neuquino 22.01.2013 21:55
4

Benim durumumda, sorun systemd-logind 'nin yeniden başlatılmasıyla çözülebilir:

systemctl restart systemd-logind

Bu, Serverfault 'dan bahsedilmektedir.

Bunu düzenli olarak yapmalıyım ve sorunun kök nedeninin ne olduğunu bilmiyorum.

    
verilen cevap Candid Dauth 22.04.2016 19:01
1

Benim durumumdaki ssh için hata ayıklama çıkışı, bağlantı kurulurken 30 saniye durdu. Çözüm yerel sistemimin DNS ayarları ile ilgili olduğu ortaya çıktı. Önceki bir ağ yapılandırması, /etc/resolv.conf dosyasında sahte bir DNS sunucusunun arkasında kalmıştı. Mevcut bir DNS sunucusu ile değiştirmek sorunu çözdü.

    
verilen cevap ErikWeitenberg 25.07.2014 18:29
0

Benim için sistem dns'i 127.0.0.1 olarak değiştirdi, bundan önce mevcut olmayan bir ana bilgisayardı.

nano /etc/resolv.conf

Ve aşağıdakileri yazın

domain localdomain
search localdomain
(Removed this line) ===> nameserver 10.0.0.1
(Added this line) ===> nameserver 127.0.0.1
    
verilen cevap Alireza 07.12.2013 06:51
0

Posterin ortamı hakkında istediğim kadar bir şey bilmiyorum, ancak benzer bir sorunu olan başkaları için, sssd ile ldap mojo'yu bağlamak için kullandığımız bir sorun olabilir.

Bu bana olur:

$ time ssh server.example.com

real  2m0.018s
user  0m0.006s
sys   0m0.004s

Sunucuya erişmem gerekiyor (benim durumumda konsol aracılığıyla), sonra şunu yapın:

service restart sssd

Bundan sonra işler işe yarıyor. Kök nedenini ayıklamak için zamanım olmadı, ama bu bandaj benim için çalışıyor.

    
verilen cevap KurtB 15.09.2014 20:36
0

yavaş parola sorgusunu ssh aracılığıyla çözebilirim - sorun, dlink yönlendiricimde DHCP ayarlarında DNS Aktarmayı Etkinleştir 'i işaretleyerek. Daha sonra SSH ile bağlantılar bir saniye içinde çalıştı.

Network Settings -> Router Settings -> Enable DNS Relay [x]

Varsayılan yapılandırma, sağlayıcıya her DNS isteğini iletir. Ssh [email protected] ile bağlantı kurmamda yavaştı. Çözüme bir ipucu, dhcp yoluyla sağlanan /etc/resolv.conf "search upc.at" içindeki bir girdiydi.

dlink manuel durumu:

When DNS Relay is enabled, DHCP clients of the router will be assigned 
the router's LAN IP address as their DNS server. All DNS requests that 
the router receives will be forwarded to your ISPs DNS servers. 
When DNS relay is disabled, all DHCP clients of the router will 
be assigned the ISP's DNS server.

İstemci ve sunucuda bir dhcp sürümünden sonra SSH ile bağlantı yeniden hızlı oldu. HTH.

    
verilen cevap domih 19.06.2015 21:11

Etiketlerdeki diğer soruları oku