Ubuntu'ya Skype 4.3 kurmuyor 14.04 64 bit

19

Her şeyden önce, bu sorunun kopyalanmadığını düşünüyorum çünkü burada bulduğum tüm diğer çözümleri denedim, ancak hiçbir şey sorunumu çözmedi.

Ubuntu 14.04 64 bit kullanıyorum.

Şimdiye kadar denedim: sudo apt-get install skype - & gt; İşe yaramadı. Hata:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

sudo dpkg add-architecture & amp; & amp; sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb ancak bu işe yaramadı. Hata:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
skype depends on libqt4-network (>= 4:4.8.0); however:
Package libqt4-network:i386 is not installed.
skype depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml:i386 is not installed.
skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Package libqtcore4:i386 is not installed.
skype depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4:i386 is not installed.
skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
skype depends on libstdc++6 (>= 4.2.1); however:
Package libstdc++6:i386 is not installed.
skype depends on libx11-6; however:
Package libx11-6:i386 is not installed.
skype depends on libxext6; however:
Package libxext6:i386 is not installed.
skype depends on libxss1; however:
Package libxss1:i386 is not installed.
skype depends on libxv1; however:
Package libxv1:i386 is not installed.
skype depends on
dpkg: error processing package skype (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
skype

Sudo apt-get -f install 'den sonra kullanmaya çalıştım ama çözmedi.

Gdebi 'yi kullanarak yüklemeyi denedim. Hata:

Cannot install 'libqtwebkit4:i386'

Ubuntu Yazılım Merkezi 'yi kullanarak yüklemeyi denedim. Hata:

Cannot install 'libqtwebkit4:i386'

Sunucuyu "Yazılımlar ve Güncellemeler" de değiştirmeyi denedim. "Ana Sunucu" ve "Amerika Birleşik Devletleri için Sunucular" kullanmayı denedim. Ama sorunumu çözemedi.

Herkesin bunu nasıl çözeceğine dair bir fikri var mı?

ÇÖZÜLECEK

Bilgisayarımı biçimlendirdim ve her şeyden önce Skype'ı kurdum. Muhtemelen, Skype instalasyonundan önce yaptığım bir başka kurulum problemdi, sanırım.

Teşekkürler millet!

    
sordu z_inx 30.07.2014 20:29

9 cevap

32

14.04 64bit çalıştırıyorum, nasıl yükledim.

buradan skype 4.3’ü indirdim ve Gdebi'yi yüklemek için kullanmış ve iyi kurulmuş. Gdebi yüklü değilse, Terminal'i açmak için klavyenizde Ctrl + Alt + T tuşlarına basın. Açıldığında, aşağıdaki komutları çalıştırın:

sudo apt-get install gdebi

Söylediğim gibi, yukarıda belirtilen yöntemi kullanarak herhangi bir kullanımım olmadı. Kırılmış paketleri düzeltmek için yapabileceğiniz bir başka şey yapabilirsiniz.

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

VEYA

Yüklüseniz, sinaptik paket yöneticisine gidin, Düzenle - & gt; Bozuk Paketleri Düzeltin.

Yüklemek için alternatif bir yol,

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Bundan sonra 'libqtwebkit4: i386' veya başka bir paket yükleyemiyor gibi bir hata alırsanız, bu komutu deneyin.

     sudo apt-get upgrade --fix-missing

Aşağıdaki komutu denemenizi tavsiye eder.

    sudo apt-get -f install

Yukarıdaki komutu yürüttükten sonra, bir kez daha deneyin.

sudo dpkg -i skype-install.deb

Daha fazla ayrıntı için resmi Skype forumuna bakın burada .

Bunun size yardımcı olacağını umuyorum :)

    
verilen cevap Mitch 30.07.2014 20:44
4

İlk çalıştırma:

sudo apt-get install -f

OS 14.04LST 64 bit ile ilgili depsleri kurmak ve daha sonra aşağıdaki komutları deneyin ... skype 4.3 mükemmel kurulur

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Benim için çalıştı .... ;;;; :)

    
verilen cevap suri 05.08.2014 16:13
2

Aşağıdaki komutları çalıştırmak:

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

Sorunu benim için çözdü.

    
verilen cevap nick 05.08.2014 14:26
2

Adım:

sudo sh -c "echo 'deb http://archive.canonical.com/ubuntu/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
    
verilen cevap John Foley 21.10.2014 22:54
1

Ubuntu 13.10'da Skype 4.3 ile aynı problemi çözdüm. Ancak, yukarıdaki talimatları uygularken Skype 4.2, daha yeni sürümü indirmeden önce Skype'ı kaldırırken bile her zaman gösteriliyor. Çalışması için, ev dizimdeki .Skype yapılandırma dosyasını kaldırmam gerekiyordu:

rm -r ~/.Skype

Endişelenmeyin, kişilerinizi veya başka bir şeyinizi kaybetmezsiniz. İlk başta görebildiğim en ufak bir rahatsızlık, bazı kişileriniz skype adlarıyla ve tanıdık tam adla görünmeyecek.

    
verilen cevap Marc Corluy 25.08.2014 12:59
1

Benim durumumda, RTFM ilkesini takip etmemekle aynı sorunu yaşıyorum :) Xorg-edgers'den bazı paketler yükledikten sonra kurulum yorumunda söylendiği gibi düzgün bir şekilde kaldırılmadılar (yani, sadece depoyu kaldırdılar, ancak kurulu paketleri değil). Bu, herhangi bir i386 kitaplığına bağımlı paketi kuramaya uygun olmayan bir domino etkisine neden oldu ...

Doğrudan sorunları (64 bit paketlerin farklı sürümleri) ayrıntılı olarak belirten yetenekleri olan paketleri yüklemeyi deneyerek buldum. Sonra xorg-edgers deposunu ekledim ve düzgün bir şekilde kaldırdım:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

Umarım birilerine yardım eder ...

    
verilen cevap Karel Lenc 25.08.2014 19:42
1

"Yazılım ve Güncelleştirmeler" denetim masasında "Güncelleştirmeler" sekmesinde "Önerilen Güncelleştirmeler (güvenilir güncelleştirmeler)" özelliğini etkinleştirerek aynı sorunu giderdim.

    
verilen cevap Douglas Held 24.11.2014 19:04
0

4.3.0.37 sürümüne yükselttim çünkü 4.2.0.13 sürümü "Bağlanılamıyor" hatasıyla artık giriş yapmama izin vermiyordu .

Maalesef, saatlerce çalıştıktan sonra, sistemimde çalışmak için pulseaudio alamadım, sadece ALSA çalışıyor, bu yüzden 4.2.0.13 sürümüne geri döndüm

Oturum açma hatasını çözmek için 4.2.0.13 sürüm numarasını en son 4.3.0.37 sürümüne taklit ettim ve giriş tekrar çalışıyordu, sorun çözüldü.

Sorununuzu çözmek için 4.2.0.13 'e geri dönün ve 4.3.0.37 sürümüne not alın, Skype'tan çıkın ve şu komutu çalıştırın:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

Sonra normal olarak giriş yapabilmeniz gerekir.

    
verilen cevap mikelinux 12.08.2014 09:03
0

Yukarıdakilerin hepsini deneyen, ancak hala (benim gibi) mücadele edenler için:

Sorun, Ubuntu güncellemeniz için kullandığınız sunucu olabilir (benim durumumdaydı). Kullandığım sunucu libqtwebkit4:i386 doğru tanımına sahip değildi.

Bunu çözmek için:

  • Sistem Ayarlarını Aç
  • Yazılım & amp; Güncellemeler
  • Ubuntu Yazılım sekmesi
  • Şuradan indir (Diğer ... ve En iyi sunucu seçeneğini seçin)

Sisteminizi sudo apt-get update ile güncelleyin ve ardından:

wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Benim için çalıştım.

    
verilen cevap Raphael_b 15.05.2015 18:17

Etiketlerdeki diğer soruları oku