Intel kablosuz kartları ile makinelerde yavaş kablosuz nasıl düzeltilir?

21

Önceki tüm soruları inceledim, ancak Wi-Fi kartı için güç yönetimini kapatma işlemi çalışmadı. Bu sorun, Lenovo Thinkpads ile görünüyor. Windows 7'den Ubuntu 11.10'a 3 gün önce geçtim, bu yüzden işletim sistemine yeniyim.

    
sordu Kaine McAliece 07.04.2012 02:18

8 cevap

20

OP Gönderildi:

  • Not1: Yavaş bağlantı servis sağlayıcınız veya başka bir nedenden dolayı olabilir, kontrol etmek, aynı ağa farklı bir işletim sistemi veya bir kabloyla ağa bağlanarak başka bir bilgisayar tarafından denenebilir. Eğer hızlıysa, bu çözüm size yardımcı olabilir. Değilse, zaman kaybı olabilir! *

  • Not2: Verdiğim Referanslar'ın ilk bağlantısında, yavaş kablosuz bağlantıyı çözmek için daha fazla yöntem var. Her yöntem yavaş bağlantının farklı olası nedenlerini çözer. Muhtemelen etkili olduğu için farklı yöntemler aramadan önce buraya koyduğum çözümü denemenizi tavsiye ederim. *

Ubuntu 11.10 kullanıyorsanız, aşağıdakileri yapın:

terminali aç. Aşağıdaki iki satırı yazın:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

Şimdi kablosuz İnternet hızınızı kontrol edin. Eğer hala yavaşsa, bu çözüm muhtemelen sizin durumunuz için bir çözüm değildir. Bu durumda, yaptığınız değişikliği geri almak için bilgisayarı yeniden başlatmanız yeterlidir. Normal ve hızlı olursa, terminalde aşağıdaki satırı yazarak kalıcı olarak yapın:

gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf

Bir dosya açılacak. Dosyanın sonunda, aşağıdaki satırı yapıştırın ve kaydedin:

options iwlagn 11n_disable=1

Kaydetme işleminden sonra, çıkın ve ENJOY!

Ubuntu 12.04 için Çözüm:

terminali aç. Aşağıdaki iki satırı yazın:

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Şimdi kablosuz İnternet hızınızı kontrol edin. Eğer hala yavaşsa, bu çözüm muhtemelen sizin durumunuz için bir çözüm değildir. Bu durumda, yaptığınız değişikliği geri almak için bilgisayarı yeniden başlatmanız yeterlidir. Normal ve hızlı olursa, terminalde aşağıdaki satırı yazarak kalıcı olarak yapın:

gksudo gedit /etc/modprobe.d/iwlwifi-disable11n.conf

Bir dosya açılacak. Dosyanın sonunda, aşağıdaki satırı yapıştırın ve kaydedin:

options iwlwifi 11n_disable=1

Kaydetme işleminden sonra, çıkın ve ENJOY!

Kaynaklar:

* Her iki çözümü de denedim ve çalışıyorlar.

    
verilen cevap Jorge Castro 05.05.2012 01:03
10

Bunu buradaki talimatları kullanarak çözdüm.

bir terminalde yaz:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rfv iwlagn
sudo modprobe iwlagn

12.04 ve üstü için: options iwlagn 11n_disable=1 - options iwlwifi 11n_disable=1

değiştir     
verilen cevap eskararriba 11.04.2012 03:14
4

12.04 için, değiştirin:

options iwlagn 11n_disable=1

Kime:

options iwlwifi 11n_disable=1
    
verilen cevap eskararriba 30.04.2012 20:52
3

Bu hata dizüstü bilgisayarımı Centrino Ultimate-N 6300 ile de etkiler. Yardımcı olan tek şey swcrypto parametresini açmaktı. % Co_de% şimdi şunun gibi görünüyor:

options iwlwifi 11n_disable=1 led_mode=1 swcrypto=1

Ve wifi'yi sorunsuz kullanabilirim. Ancak, n-ağlarının kullanılamaması gerçeği can sıkıcıdır.

    
verilen cevap Karl Frisk 02.08.2012 00:07
2

Bu komutlar benim için işe yaradı ve çalıştı, Kubuntu 15.10 (akıllıca), Intel Wifi Adaptörüm (Intel Corporation Centrino Wireless-N 1000) bir taramadan (salyangoz hızı) çoğunlukla tam hıza gitti:

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlagn.conf
echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Bunu bulmak için ilk başta çok zorlandım, umarım birilerine yardım eder, ilk başta Linux'u kurduğumda (Kubuntu), beni çıldırtıyordu:)

    
verilen cevap David V. 04.11.2015 03:48
1

GÜNCELLEME: Bir şekilde tekrar bağlanmadı, bu yüzden daha fazla araştırma yaptım, bulduğum şey:

iwlwifi dosyasındaki orijinal iwlwif.conf komutlarını ( iwlwifi.conf 'deki orijinal komutları geri yüklemek gerekli olmayabilir) /etc/modprobe.d/iwlwifi.conf ' da geri yükleyin ve bu satırı en sonunda yapıştırın:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Dosyayı geri yüklemek için iwlwifi.conf adlı belgenizdeki yeni bir metin dosyası oluşturabilir ve komut satırlarını ekleyebilirsiniz:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Sonra belgeyi kaydedin ve konsole’yu çalıştırın ve komutları girin

sudo cp /home/[replaceyourusernamehere]/Documents/iwlwifi.conf /etc/modprobe.d/iwlwifi.conf

Bundan sonra, daha önce girdiğim zaman wifi'm daha hızlı çalışmaya başladı:

options iwlwifi 11n_disable=1

Not: Yukarıdaki dosya benim için çalıştı ve süper filtreyi kullanarak dosyayı kopyaladım. Bu kısmı aşağıda yapmadım ama işe yarayabilir ya da çalışmayabilir.

Hala komutları şu şekilde çalıştırmanız gerekebilir:

echo options options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Daha önce çalıştırdığımda hala iwlwifi hata modülünü kullanıyordum:

sudo modprobe -rfv iwlwifi.

Bunun sizin için işe yarayıp yorumlamadığını bildirin.

    
verilen cevap David V. 07.11.2015 07:02
1

Bir terminali açın ( Alt + Ctrl + T ) ve şunu yazın:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Şimdi hızların düzelip düzelmediğini kontrol edin. Eğer evet kalıcı hale getirirse.

  1. /etc/modprobe.d/iwlwifi_disable11n.conf 'yi süper kullanıcı olarak aç, e. q:.

    gksudo gedit /etc/modprobe.d/iwlwifi_disable11n.conf
    
  2. Dosyanın sonuna aşağıdaki satırı ekleyin:

    options iwlwifi 11n_disable=1
    
  3. Bundan sonra kaydedin ve çıkın!

Gibi bir hata alırsanız

ERROR: Removing 'iwlwifi': No such file or directory

Yukarıdaki kodlarda iwlwifi iwlagn ile değiştirin ve tekrar deneyin.

    
verilen cevap Mukund 20.12.2012 17:47
0

Dizüstü bilgisayarımda 801.11n'yi kullanamadığından birkaç yıl sonra. Bu sorunu gerçekten düzelten bir çözüm buldum! Bu mümkün olan en iyi çözüm gibi görünüyor, çünkü hala bluetooth kullanabiliyorsunuz ve 801.11n ile ağlara da sorunsuzca ulaşabiliyorsunuz (~ 70Mbps alıyorum).

Aşağıdaki komutları bir terminale girin:

echo options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi-disable11n.conf

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

İşte yaptığımız şeyle ilgili bir açıklama:

  • swcrypto=1 , yazılım şifrelemesi için donanım şifrelemesini değiştirir.
  • bt_coex_active=0 bluetooth ve kablosuz bağlantı kapalı arasındaki otomatik parazit özelliğini kapatır - bu büyük olasılıkla sorunların gerçek sebebidir.
  • 11n_disable=8 , TX AMPDU toplamasını etkinleştirir.

bt_coex_active gerçekte ne zaman etkinleştirilir? Sistem, bluetooth frekansının kullanıldığını düşündüğü zaman wifi'yi "muting" yapmaktır - ama buggy uygulamalarında, bluetoothun her zaman iletildiğini varsayar, böylece wifi kapanır kalıcı.

Çoğu kişi varsayılan /etc/modprobe.d/iwlwifi.conf dosyasını değiştirmeyi tercih etse de, kişisel olarak, gerektiğinde geri alınabilmesi için ayrı bir dosyaya koymayı tercih ediyorum. Önceki ince ayarları denediyseniz, lütfen dosyanızın varsayılan ayarlara geri döndüğünü kontrol edin. Referans mayın için (Ubuntu 16.04'te):

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Bu işlem sizin için uygun değilse lütfen şunu çalıştırın:

sudo rm /etc/modprobe.d/iwlwifi-disable11n.conf

Kaynaklar:

İşte

Benim Kullanımım (milajınız değişebilir):

  • İşletim Sistemi: Ubuntu 16.04 (yeni ve eski sürümde de çalışacak!)
  • Donanım: Intel Corporation Centrino Wireless-N 1000 [Condor Peak] (ancak benzer modellerde çalışacaktır, örneğin Intel Centrino 6235!)
verilen cevap hazrpg 23.05.2017 03:15

Etiketlerdeki diğer soruları oku