Eclipse'nin “Güncellemeleri kontrol et” neden çalışmıyor

19

Sadece yeni bir 12.04 Kesinlik yüklemesi yaptım. Eclipse'de "Yardım" & gt; "Güncellemeleri kontrol et" Ben "Bu güncellemeyi uygulamak için yetersiz erişim ayrıcalıkları" mesajıyla gri olan 8 paketi görüyorum. Bunu nasıl düzelttiğime dair bir fikrin var mı?

    
sordu Ben McCann 27.04.2012 02:10

5 cevap

6

Ubuntu deposundan Eclipse'i yüklerseniz, Eclipse yüklemesi root'a ait olacaktır. Temel paketleri güncellemenin doğru yolu, Eclipse güncelleme araçlarını değil Ubuntu yükseltme araçlarını kullanmaktır. Çalışma Alanınıza eklentilerin yüklenebileceğine inanıyorum, ancak paket yöneticilerini karıştırmanızı önermem.

Eclipse güncelleme işlemini kullanmak istiyorsanız Eclipse indirme sitesinden Eclipse'i indirmeniz gerekir. Bunu yaptığımda, kullanıcı kimliğimin orada yazılması için ayrıcalıklarını ayarladıktan sonra / opt / altında yükledim. Eclipse'i çalıştırmak için kullanacağınız kullanıcı olarak paketleyin.

DÜZENLEME: Çoğu zaman, /opt 'den 1777 ' ya kadar olan herkesin buradaki paketleri oluşturmasına izin vermek için izinlerim. Alternatif olarak chgrp users /opt kullanın ve izinleri 1775 olarak ayarlayın. Bu, kullanımlar grubunun üyelerine /opt 'ye yeni paketler eklemesine izin verir.

    
verilen cevap BillThor 27.04.2012 02:33
4
sudo eclipse

İşi benim için yaptım, yeni yazılım (eclipse add-ons) yükleyebildim ve Eclipse yeniden başlatıldıktan sonra.

    
verilen cevap user137263 03.03.2013 19:21
2

Eclipse'de büyük bir uzman değilim, ancak benim anlayışım Eclipse'in kendi güncelleme sisteminin Ubuntu güncelleme sistemi ile eşzamanlı bir şekilde gerçekleşmesidir (bu, Python modülleri gibi kendi güncelleme yöntemlerine sahip diğer birçok paket için de geçerlidir) - apt-get install kullanarak Ubuntu depolarından veya easy_install kullanarak Python paket dizininden yükleyebilirsiniz.

Bu durumda, Ubuntu olmayan diğer güncelleme mekanizması, doğal olarak root ayrıcalıklarına ihtiyaç duyan Ubuntu depolarından yüklenen dosyaları geçersiz kılmaya çalışacaktır. Ayrıca, bunun iyi bir fikir olduğundan emin değilim - Ubuntu depolarından kısmen yüklenmiş ve kısmen uygulamanın güncelleme sistemini kullanan toplam dosya karmaşası yaratması olasıdır.

Önemli olan - Ubuntu depolarından Eclipse'i yüklediyseniz, Ubuntu depolarından edinilebilecek güncellemeleri kullanmanız ve Eclipse'deki "Güncellemeleri denetle" seçeneğini yok saymanız daha iyidir. Bazı Eclipse eklentisine / uzantısına ihtiyacınız varsa, bunu ayrıca Software Center'dan yüklemelisiniz.

Eclipse paketlerinin Ubuntu sürümleri sizin için yeterince kanama değilse, Eclipse'in ayrı bir kopyasını kendi web sitelerinden indirip (bu şekilde Eclipse sürümünü de seçebilirsiniz) ve ev dizininizden çalıştırmanız önerilir. - Bu aslında oldukça kolaydır. Ardından, Eclipse'in kopyasını kendi güncelleme mekanizmasını kullanarak güncelleyebilecek ve Ubuntu reposlarında bulunmasalar bile eklentileri yükleyebileceksiniz.

    
verilen cevap Sergey 27.04.2012 02:32
1

Ubuntu Yazılım Merkezi

Ubuntu Yazılım Merkezi üzerinden bir paket kuruyorsanız, Eclipse içinden güncellememelisiniz (OS yazılımı güncelleme servisi bu değişiklikleri yapar).

Kendi uygulama sürümünüzü yönetmek istiyorsanız, doğrudan Eclipse'den indirmeniz gerekir (yakın zamanda Android Geliştirme için özel sürüm ).

El ile Kurulum

Yalnızca tek kullanıcı için (en kolay)

  • Paketini açtım ve evime yeni bir alt dizin ~/bin/ kopyaladım.
  • Android SDK'yı Eclipse için dropin klasörüne koydum (durumum ~/bin/eclipse/dropins/ )
  • ADT Eklentisi 'nin yüklenmesiyle ilgili diğer adımlara devam ettim. Android SDK için özel bir yol kullandığından , Eclipse Penceresi & gt; Tercihler.

Tüm kullanıcılar için kurulum

  • android-studio böylece android-studio'dan Eclipse özelliklerine yapılan referansları değiştirmelisiniz .
  

android-studio 'un tüm kullanıcılar tarafından kullanılabilir olmasını istiyorsanız (   Yukarıdakiler katranı /opt yerine paketinden çıkarmalısınız.    /usr/local veya /usr/bin (ikincisi   belirli kullanıcı yüklemeleri). Düzgün kur, ihtiyacımız olmamalı   kullanıcı grubu izinlerini veya herhangi bir üst düzey yönetimini değiştirin.

     
  1. .tar dosyasını bulunduğu yere koyun
  2.   
  3. Bir Terminal penceresi kullanarak, bu klasör konumuna gidin (muhtemelen cd ~/Downloads ), sudo -i çağırırsınız.   sonraki birkaç adım için yönetici / su izinleri)
  4.   
  5. mv android-studio /opt , paketini açtığınız dosyaları taşır (izin gerektirir)
  6.   
  7. gedit android-studio.desktop bu bir metin düzenleyicisini açar, böylece yeni programınızı açmak için bir kısayol simgesi oluşturabiliriz. Ekle   Aşağıdaki kodu, ardından .desktop dosyasını kaydedin.
  8.   
    [Desktop Entry]
     Name=Android-Studio
     Comment=your comments
     Exec=/opt/android-studio/bin/studio.sh
     Icon=/opt/android-studio/bin/idea.png
     Terminal=false
     Type=Application
     Categories=Utility;IDE;Development;
  
  • Bitirmek için, desktop-file-install android-studio.desktop
  •   

Terminal penceresi ile işimiz bitti, kapatabilir veya exit Bu   .desktop dosyası artık android-stüdyo aramanızı ve bulmanızı sağlıyor.   Ubuntu'nun Birlik arayüzü içinde. Başka bir deyişle, o simgeyi   android-stüdyo aramak için sol üstte sağ tıklayabilirsiniz   simgesi çalışırken ve "başlatıcıya kilitle".

     

Ayrıca uygulamanız için görünecek menü seçeneklerini de oluşturabilirsiniz.   başlatıcısı, Unity Launcher'daki Ubuntu Belgelerine bakın.

    
verilen cevap Clayton 17.09.2012 21:44
0

Eclipse'in güncelleme mekanizması Ubuntu'nun paket yönetim sistemi (PMS) hakkında bilgi sahibi değildir veya iletişim kuramamaktadır. Bu nedenle, Eclipse'in güncelleme mekanizmasını kullanarak güncelleştirirseniz, Ubuntu'nun PMS'si (dosyalar senkronizasyon, yapılandırılmış yapılandırmalar vb.) Arasında sorunlara neden olabilirsiniz.

Ciddi bir geliştiriciyseniz ve Eclipse'in daha sonraki sürümlerine ihtiyacınız varsa, Eclipse'in PBS'in Eclipse'in söz konusu olduğu tarihte her zaman bu kadar modası geçmiş olduğu için, Eclipse'i Ubuntu'nun PMS'si dışında kurmanız daha iyi olur. Örnek: Ubuntu 14.04 LTS'deyim ve bunu göndermeden önce sudo apt-get update && sudo apt-get upgrade yaptıktan sonra bile, PMS aracılığıyla mevcut olan en son Eclipse sürümü 3.8.1-5.1, ancak 4.6.1 bir süredir açıktı. Bu her zaman böyle olmuştur - Ubuntu PMS'de bulunan Eclipse sürümü her zaman büyük ölçüde son derece günceldir.

    
verilen cevap Echelon 21.11.2016 20:29

Etiketlerdeki diğer soruları oku