Google Chrome, Xubuntu'da varsayılan tarayıcı olarak nasıl ayarlanır?

18

Xubuntu 12.04 kullanıyorum. Firefox'u kaldırdım ve şimdi Google Chrome sürüm 19.xxx sürümünü kullanıyorum.

Bu sorunu çözmek için şunu denedim:

  • galternatives

  • Ayarlar altındaki "varsayılan uygulamalar" ve

  • sudo update-alternatives --config x-www-browser

Bunlardan hiçbiri işe yaramadı. Bunun için alternatif bir çözüm olan var mı?

- & gt; Çözüm: "sudo gedit /usr/share/applications/defaults.list" ipucunu 天使 の kullanarak kullandım ve tüm belgede firefox'u aradım! Her zaman "firefox" bulduğumda onu "google-chrome.desktop" ile değiştirdim. Google Chrome’u değiştirmek için "varsayılan uygulamalar" menüsünü de kullandım. Ve şimdi çalışıyor .. Umarım başkalarına yardımcı olur; -)

    
sordu mpm 28.05.2012 12:33

10 cevap

27

ÇÖZÜLDÜ:

Dinle, bunu yapmanın kolay yolu, xfce4-settings-manager'ı root olarak açık olarak

sudo bash
xfce4-settings-manager

veya

gksu xfce4-settings-manager

ardından tercih edilen uygulamaları seçin ve tarayıcıların altında başka birini seçin ve yapıştırın:

/usr/bin/X11/chromium-browser

kapat ve sonsuza kadar tüm kullanıcılar için iyisin. : D

    
verilen cevap Eric Sebasta 08.11.2012 17:55
11

Belki de bu yolu kullan

gksudo gedit /usr/share/applications/defaults.list

x-www-browser bulmayı deneyin ve değerini google-chrome.desktop konumunuza ayarlayın

DÜZENLEME

x-www-browser değerini bulamazsanız, ardından
arama yapmayı deneyin

text/html=firefox.desktop;google-chrome.desktop
text/xml=firefox.desktop;google-chrome.desktop
application/xhtml_xml=google-chrome.desktop
x-scheme-handler/http=firefox.desktop;google-chrome.desktop
x-scheme-handler/https=firefox.desktop;google-chrome.desktop
x-scheme-handler/ftp=google-chrome.desktop
    
verilen cevap hingev 28.05.2012 12:49
2

İlk önce firefox 'yi bu belgedeki her yerde chromium-browser ile değiştirmeyi denedim:

gksudo gedit /usr/share/applications/defaults.list

Çalışmıyordu. Yine de Firefox, Chromium yerine belgelerimi açardı.

Sonra bu alternatifi yaptım:

sudo update-alternatives --config x-www-browser

Üç alternatifiniz var:

0 - auto
1 - manual Chromium-browser
2 - manual Firefox

0 öğesini seçtim. Şimdi çalışıyor!

    
verilen cevap Jorge 07.01.2013 15:32
2

Alt ekrandaki 'Web Tarayıcısı' kısayolunu kastettiyseniz, tıklattığınızda, kullanmak istediğiniz tarayıcıyı seçmeniz istenecektir ve listede krom yok mu?

Sadece "Diğer ..." yi (aşağı açılır menünün en altında) seçip 'google-chrome' yazıp tamam'a basın.

Artık daha sonra tıkladığınızda chrome açılacaktır.

Mutlu Xubuntuing! ;)

    
verilen cevap Bubz90 22.06.2012 18:15
1

"Ayarlar yöneticisi" nde "tercih edilen uygulamaları" seçin. Chromium yürütülebilir dosyasının yolu /usr/bin/X11/chromium-browser . Seninle aynı sorun vardı ve bu çözüldü.

    
verilen cevap vinster171 03.06.2012 20:25
1

Linux Mint 14'te varsayılan olarak SRWare (Demir Tarayıcı) kurma yönergeleri:

sudo apt-get install chromium (veya sinaptik kullanın) ..

sudo apt-get install galternatives sonra .....

sudo update-alternatives --config x-www-browser

Şimdi seçenekleri göreceksiniz ve şimdi krom görmelisiniz (benim için 0 seçeneğiydi. seç ve Enter'a bas)

Örnek:

  0            /usr/bin/chromium-browser   40        auto mode
  1            /usr/bin/chromium-browser   40        manual mode
  2            /usr/bin/firefox            40        manual mode

Şimdi "tercih edilen uygulamalar" a gidin ve krom göreceksiniz, bunu Chromium olarak değiştirin.

Şimdi IRC'deki linkleri seçerek ect., Demir Tarayıcıyı açacak ve varsayılan Firefox'u açacak ve zaten açılmış olan Demir'in olduğu sürece Chromium'da açılmayacak!

Mutlu günler yine burada! \ O /

(bunlardan herhangi birini yapmadan önce kromu yüklemezseniz, x-www tarayıcıda, yapılandırma düzenleyicide veya tercih edilen uygulamalarda başka seçenek göremezsiniz)

Umarım bu, Demir'in yeri boyunca gördüğüm tüm şikayetlerin Mint'te varsayılan olarak ayarlanmasına yardımcı olur! :)

    
verilen cevap Lyn 28.02.2013 18:01
1

Xubuntu 14.04 LTS

Chrome'u XFCE için varsayılan tarayıcı olarak yapın.

gedit ~/.local/share/applications/mimeapps.list

[Added Associations]
text/plain=gedit.desktop;openoffice.org-writer.desktop;
application/x-shellscript=gedit.desktop;
x-scheme-handler/http=google-chrome.desktop;
x-scheme-handler/https=google-chrome.desktop;
x-scheme-handler/ftp=google-chrome.desktop;
x-scheme-handler/chrome=google-chrome.desktop;
text/html=google-chrome.desktop;
application/x-extension-htm=google-chrome.desktop;
application/x-extension-html=google-chrome.desktop;
application/x-extension-shtml=google-chrome.desktop;
application/xhtml+xml=google-chrome.desktop;
application/x-extension-xhtml=google-chrome.desktop;
application/x-extension-xht=google-chrome.desktop;
inode/directory=Thunar-folder-handler.desktop;
application/xml=gedit.desktop;
application/pdf=qpdfview.desktop;

[Default Applications]
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/ftp=google-chrome.desktop
x-scheme-handler/chrome=google-chrome.desktop
text/html=google-chrome.desktop
application/x-extension-htm=google-chrome.desktop
application/x-extension-html=google-chrome.desktop
application/x-extension-shtml=google-chrome.desktop
application/xhtml+xml=google-chrome.desktop
application/x-extension-xhtml=google-chrome.desktop
application/x-extension-xht=google-chrome.desktop
application/pdf=qpdfview.desktop
    
verilen cevap Zoltán Mózes 01.10.2015 15:41
0

Chrome 18 ile 11.04 çalışıyorum ve Chrome'un Ayarlar içindeki varsayılan tarayıcıyı ingiliz anahtarı menüsü aracılığıyla değiştirebiliyorum.

Ana Ayarlar sayfasının en altındaki, varsayılan tarayıcı için bir düğme. Açık bir harici başvurum vardı. İlk kez Firefox başladı. Değişiklikten sonra, uygulamalardan herhangi birini yeniden başlatmadan harici uygulamadaki bir bağlantıya tıklandığında yeni bir Chrome sekmesi açılır.

Bunu denediğinizi söylemediniz, bu yüzden bunun 12.04 ile ilgili bir sorun olup olmadığını bilmiyoruz.

Düzenleme: Chrome'un ayarlarının, Ubuntu'da olduğu gibi Xubuntu'da istenen etkiye sahip olmaması olabilir. Daha fazla bilgi, bir yanıt bulmamıza yardımcı olabilir.

    
verilen cevap nibl 04.06.2012 01:57
0

Bu hala 13.04'te bozuldu. Chrome'u yükledim ve şimdi başka bir uygulamada bir bağlantıyı tıklattığımda, hangi tarayıcıyı varsayılan yapmak istediğimi sorar (krom tarayıcıya tıklıyorum); ve Chrome'u her başlattığımda, varsayılan tarayıcıyı (evet) yapmak isteyip istemediğimi sorar.

Bu ayar neden yapışmıyor? Ubuntu devresindeki biri Chrome için içeri mi aldı?

Bu, 12.04'ten beri bir sorun oldu ve hala sabit değil. Komut satırı veya yapılandırma düzenlemesi ile düzeltmek, uzmanlar ve sistem yöneticileri için iyidir, ancak şu ana kadar tüm kullanıcılarıma açıklamak zorunda kaldım. Birisi kodu kirletti ve bunu el ile yapmalısınız ve belki de bir gün düzeltecekler.

Bu tür bir şey asla düzelmediğinde gerçekten kötü görünüyor.

    
verilen cevap Peter Flynn 02.03.2014 15:20
0
gvfs-mime --set x-scheme-handler/http google-chrome.desktop
gvfs-mime --set x-scheme-handler/https google-chrome.desktop
gvfs-mime --set text/html google-chrome.desktop
    
verilen cevap momo 07.09.2016 18:40

Etiketlerdeki diğer soruları oku

16.04'te çalışmak için Logitech MX Anywhere 2'yi nasıl alabilirim (Bluetooth akıllı) ___ answer520915 ___

Aslında %code% paketinin kendisini bulamadım. Ne yardımcı oldu:

%pre%

Ubuntu 14.04 x64

    
___ Paylaşılan Kütüphaneleri Yüklerken Hata (libGLU.so.1) ___ answer386732 ___

Bunu anladım. 32 bit sürümleri yüklemeliydim.

Aynı problemi olan ve 64 bit işletim sistemi çalıştıran herkes için. Eksik dosyaları içeren paketleri bulun ve kullanın:

  

sudo apt-get yükleme paketi: i386

"Paket" paketinin adını değiştirin. ": İ386" olmadan, yalnızca 64 bit sürümünü kuracaktır.

    
___ answer575808 ___

Bunu sadece 32 bit veya 64 bit referans olmaksızın yüklemem gerekiyordu.

%pre%     
___ answer731179 ___

Bazı dosyaları sildiğimde aynı türde bir sorun yaşadım, bu komutu kullanarak onları geri aldım

%pre%

Umarım işe yarar.

    
___ answer492716 ___

Ben oynamak istedim (The Fall) bir oyun için libGLU.so.1 gerekli ve bu hatayı aldım:

%pre%

Bir aramadan sonra birisinin ia32-libs'den bahsettiği ve bu im ve runnig'i yükledikten sonra bir hata sayfası buldum.

bulunan sayfa bulundu:

İşte

Çalıştırdığım komut:

%pre%     
___ qstntxt ___

Ubuntu 12.10'da 64 bit AMD işlemci ile Chamsys MagicQ programını çalıştırmaya çalışıyorum.
Programı çalıştırmaya çalıştığımda bana söylediği şey bu.

  

./ magicq: paylaşılan kitaplıkları yüklerken hata oluştu: libGLU.so.1: paylaşılan nesne & gt; dosyasını açamıyor: Böyle bir dosya veya dizin yok

MagicQ için kütüphane bağımlılıklarının listesi:

  

austin @ ubuntu: ~ / magicq $ ldd ./magicq
    linux-gate.so.1 = & gt; (0xf7799000)
    libGLU.so.1 = & gt; bulunamadı     libusb-0.1.so.4 = & gt; bulunamadı     libQt5PrintSupport.so.5 = & gt; bulunamadı     libQt5OpenGL.so.5 = & gt; bulunamadı     libQt5Widgets.so.5 = & gt; bulunamadı     libQt5Network.so.5 = & gt; bulunamadı     libQt5Gui.so.5 = & gt; bulunamadı     libQt5Core.so.5 = & gt; bulunamadı     libGL.so.1 = & gt; /usr/lib32/fglrx/libGL.so.1 (0xf7694000)
    libpthread.so.0 = & gt; /lib/i386-linux-gnu/libpthread.so.0 (0xf7679000)
    libstdc ++. so.6 = & gt; bulunamadı     libm.so.6 = & gt; /lib/i386-linux-gnu/libm.so.6 (0xf764d000)
    libgcc_s.so.1 = & gt; /lib/i386-linux-gnu/libgcc_s.so.1 (0xf762e000)
    libc.so.6 = & gt; /lib/i386-linux-gnu/libc.so.6 (0xf7483000)
    libXext.so.6 = & gt; bulunamadı     libatiuki.so.1 = & gt; /usr/lib32/fglrx/libatiuki.so.1 (0xf746c000)
    libdl.so.2 = & gt; /lib/i386-linux-gnu/libdl.so.2 (0xf7467000)
    /lib/ld-linux.so.2 (0xf779a000)

Biliyorum libGLU.so.1 / usr / lib / x86_64-linux-gnu'nun "paylaşılan kütüphaneye (uygulama / x-sharedlib) bağlantısı" olarak olduğunu biliyorum. "Link hedefi:" libGLU.so.1.3.1 " Bunu nasıl düzeltirim?

    
___