Skype'ın otomatik olarak başlatılmasını nasıl önleyebilirim?

27

Kız arkadaşım Xubuntu 12.10 netbook'umdan Skype hesabına giriş yaptı ve o günden beri her açılışta Skype otomatik olarak başlıyor. Bunun olmasını nasıl engellerim?

Denediğim şeyler:

  • Ayarlar Yöneticisi - & gt; Oturum ve Başlangıç ​​-> Uygulama Otomatik Başlat'ından kaldırılıyor - listede bulamadı.
  • Skype'ta ilgili bir ayarın kontrol edilmesi - sıralamada bir şey bulamadı. (Windows'da kullandığımda benzer bir Skype ayarının olduğunu hatırlıyorum. Kız arkadaşımın bir Windows kullanıcısı olduğunu düşünürsek, bunun Windows istemcisinde var olan bir ayar olabileceğini düşünebiliriz. transfer oldu mu?)
  • Kapatmak için BUM ’ı kullanarak tekrar listeden bulamadınız.
  • Skype'ı apt-get remove skype --purge ile kaldırmayı ve tüm ayarları da sildiğini umuyordu - yapmadı.

Yeniden yükleme için kaydet, başka ne deneyebilirim?

Aynı notta iken - Skype'ın normal Başlatma rotasından geçmeden otomatik olarak nasıl başlaması mümkün olabilir?

DÜZENLEME: Denediğim birkaç şey daha:

  • Skype desteğinde benzer herhangi bir şey mi arıyorsunuz? Bir şey bulmayı beklemiyordum ve ben yapmadım.
  • Giriş dizinimdeki .Skype klasörüne bakın. Umut verici görünen birkaç dosya buldum ( .Skype/shared.xml , .Skype/[my username]/config.xml , .Skype/[girlfriend's username]/config.xml ), ancak bunlara bakmak bir şey vermedi. Çok sayıda SQLite dosyaları olsa da. Bu ayarın içinde bir yer olabilir mi?
sordu Andrey 17.03.2013 12:05

10 cevap

23

Aynı problem ve aşağıdaki gibi gözüküyormuş gibi görünüyordu: (Xubuntu) Ayarlar & gt; Oturumlar ve Başlangıç ​​& gt; Oturumu, Skype'ı bulup "Çalışıyorsa" yazıp "Asla" olarak değiştirin.

    
verilen cevap azeam 19.03.2013 10:15
28

Skype'ın yeni 2017 sürümü için, her başlatıldığında kendini otomatik başlatmaya yetecek kadar uygunsuz (ciddi olarak? Asla kendi makinem üzerine kurmadan) oluşturmaya çalıştığı dosyayla aynı ada sahip bir klasör oluşturmak yeterlidir. :

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop
    
verilen cevap int_ua 16.11.2017 13:48
13

Buradaki cevaplar her zaman değiştiği için, skypeforlinux'un bu hafta başından (8.11.0.4 sürümünden) bir yükleme olarak, otomatik başlatmayı iki adımla sona erdirmeyi başardım.

Öncelikle, Skype'ı açın, Araçlar & gt; Ayarlar ve "Skype'ı otomatik başlat" seçeneğinin işaretini kaldırın.

Ardından azeam'in önerisinden esinlenerek, (Xubuntu) Ayarlar & gt; Oturumlar ve Başlangıç ​​& gt; Uygulama Autostart ve öğeyi Skype için kaldırın. İşlerin onaylanmamasının emin değilim; Bunu denedim, ancak denediğimde Skype'ın dahili ayarları ile çakışmış olabilir.

    
verilen cevap Dan 10.12.2017 18:47
7

Aynı sorunu yaşadım. % Co_de% 'sini skypeforlinux.desktop ' den kaldırarak otomatik olarak başlatılmasını engelleyebiliyordum. Lubuntu kullanıyorum; autostart klasörünüzün konumu değişebilir. Kullanarak bulabilirsiniz:

$ locate skypeforlinux.desktop

Gerçekten sadece kopyayı ~/.config/autostart/ adlı dizinde silmek istiyorsunuz, aksi takdirde uygulamayı simgeden başlatamayacaksınız.

Bir dahaki sefere Skype'ı kasten çalıştırdığınızı varsayıyorum (umarım ki, aklınız için, bu gün gelecekte uzak ). Bu dosya geri döndü. Bu durumda, tekrar silmeniz ya da bu davranışı engelleyecek ayar için Skype'ı gözden geçirmeniz gerekebilir.

    
verilen cevap Thismatters 01.11.2017 14:44
5

Araçlar'a gidin - & gt; Seçenekler - & gt; Genel Ayarlar. "Başladığımda Skype'ı başlat" seçeneğinin işaretini kaldırın. Kaydet ve Skype'tan Çık.

    
verilen cevap Massdon1 17.03.2013 12:23
2

Kubuntu 14.04'te sorun, Başlangıç ​​ve Kapatma, ardından Oturum Yönetimi ve Başlat'ı boş bir oturum ile başlatıp Uygula'ya giderek çözüldü.

    
verilen cevap Craig 05.05.2014 20:07
1

Düzenli Ubuntu 16.04 için, "Başlangıç ​​Uygulamaları" nı arayın. Pencere açıldığında, önyüklemeden başlamasını önlemek için yalnızca onay işaretini kaldırın ve listeden silmek için Skype'ı seçerken kaldır'ı tıklayın.

    
verilen cevap yusko 20.05.2018 20:55
0

Skype'ın 'kapanması' aslında gerçekten kapanmıyor gibi görünüyor. Bunu tekrar açtığınızda, zaten giriş yapmış olmanız gerçeğiyle de fark edebilirsiniz.

Komut satırına yazarak bunu gerçekten kapatabilirsiniz:

killall skype

Bu şekilde, bilgisayarınızdan çıkış yaptığınızda çalışma oturumunuza kaydedilmez ve böylece bilgisayarınızı yeniden başlatırken otomatik olarak geri yüklenmez.

    
verilen cevap Thijs 16.08.2014 00:54
0

Skype'ı kapatmak, Skype'tan Çıkmak ile aynı şey değildir. Kubuntu'da üç şey yaptım 14.04. Skype'ı açtıktan sonra Skype (Menü) & gt; Seçenekler & gt; Genel bölümüne gittim ve "Sistem Tepsisinde Minimize Edilen Minimize Başla" seçeneğini işaretledim. Ardından Seçenekler & gt; Gelişmiş ve işaretlenmemiş "Başlangıçta güncellemeleri kontrol et". Son olarak, "Çıkış" yerine, menünün en altındaki "Çık" ı tıklattım. Bunun hile yapan son adım olduğuna inanıyorum.

    
verilen cevap WGCman 19.03.2015 01:41
0

Skype (Linux için) Ayarlar

Skype'ı Aç - Menue: extras - & gt; ayarlar - & gt; kategori: başlat ve kapat

1 . Skype otomatik başlat

ayar değiştir:

true :

/home/$USER/.config/autostart/skypeforlinux.desktop

= & gt; dosya var

false :

/home/$USER/.config/autostart/skypeforlinux.desktop

= & gt; dosya mevcut değil!

rm -rf /home/$USER/.config/autostart/skypeforlinux.desktop

Otomatik başlatmayı siler, ancak bu dosya tekrar değişiklik yaptıktan sonra oluşturulur!

Bu nedenle, kodu şu dosyadan silmek daha iyidir:

/home/$USER/.config/autostart/skypeforlinux.desktop

Autostart: = True X-GNOME-otomatik başlatma özelliği etkin

Otomatik Başlat: X-GNOME-otomatik başlatma özelliği etkin = false

sed -i 's/X-GNOME-Autostart-enabled=true/X-GNOME-Autostart-enabled=false/g' $HOME/.config/autostart/skypeforlinux.desktop

2 . Skype arka planda başlar

true :

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": true

false :

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": false

3 . Skype arka planda çalışır

true :

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": true

false :

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": false

Şununla test edildi:

  • skypeforlinux 8.18.0.6 amd64
  • Ubuntu 16.04.1 LTS
  • Tarçın
verilen cevap Werner Nöbauer 09.04.2018 14:47

Etiketlerdeki diğer soruları oku