Erişilebilirlik veri yoluna bağlanılamadı

20

X11 iletme ile ssh kullanırken, gui uygulamalarını çalıştırırken çeşitli hatalar ve uyarılar alıyorum.

Örneğin, gitg çalıştırdığım her zaman, aşağıdaki uyarıyı alıyorum:

** (gitg:15904): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ychCoQcrqT: Connection refused

Çirkin olmanın yanı sıra, bu gerçek bir hata mı gösteriyor?

evince çalıştıran aynı uyarıyı alıyorum:

** (evince:16634): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ychCoQcrqT: Connection refused

... veya eog :

** (eog:16872): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ychCoQcrqT: Connection refused

Ve benzeri.

Belki de söz etmeye değer: 12.04'ten (evet, desteklenmeyen) 13.04'e bağlanıyorum.

    
sordu Bach 11.03.2014 09:18

1 cevap

20

Uyarıların önemli olduğunu düşünmüyorum (erişilebilirlik veriyoluna ihtiyacınız olmadıkça). Görünüşe göre erişilebilirlik veriyolunu SSH üzerinden iletmek henüz desteklenmiyor.

Ancak, sizi rahatsız ederse hataları bastırmak için aşağıdakileri deneyebilirsiniz:

Aşağıdakileri herhangi bir komut için hazırlayın:

NO_AT_BRIDGE=1

Veya (uzun çekim) güvenilir iletmeyi etkinleştirmek için -Y seçeneğini SSH'de -X kullanarak kullanmayı deneyin.

    
verilen cevap Jhong 11.03.2014 09:55

Etiketlerdeki diğer soruları oku