SSH hatası: İzin reddedildi, lütfen tekrar deneyin

17

amazon ec2 örneğini kullanarak Ubuntu sunucu kurulumum var. Masaüstümü (ki bu da bir ubuntu makinesidir) SSH kullanarak ubuntu sunucusuna bağlamalıyım.

Ubuntu sunucusuna açık ssh yükledim. Ubuntu sunucusunu SSH kullanarak bağlamak için ağımın tüm sistemlerine ihtiyacım var (pem veya pub tuşlarına bağlanmanıza gerek yok).

Böylece güvenlik gruplarında (AWS) statik IP'm için SSH bağlantı noktası 22'yi açtı.

SSHD-CONFIG dosyam:

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Webmin (Komut kabuğu) aracılığıyla, 'senthil' adlı yeni bir kullanıcı oluşturdum ve bu yeni kullanıcıyı 'sudo' grubuna ekledim.

sudo adduser -y senthil
sudo adduser senthil sudo

'Webmin'de bu yeni kullanıcı' senthil 'kullanarak giriş yapmayı denedim. Başarıyla giriş yapabildim.

Ubuntu sunucusunu terminalimden SSH ile bağlamaya çalıştığımda

ssh [email protected]_IP

Şifre girmemi istedi. Şifre girişinden sonra görüntülendi:

Permission denied, please try again.

Bazı araştırmalarda, sunucumun bunun için günlük kayıtlarını izlemem gerektiğini fark ettim. Auth log'umda (/var/log/auth.log) aşağıdaki hatayı aldım

Jul  2 09:38:07 ip-192-xx-xx-xxx sshd[3037]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=MY_CLIENT_IP  user=senthil
Jul  2 09:38:09 ip-192-xx-xx-xxx sshd[3037]: Failed password for senthil from MY_CLIENT_IP port 39116 ssh2

Kullanarak hata ayıklamaya çalıştığımda:

ssh -v [email protected]_IP


    OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to SERVER_IP [SERVER_IP] port 22.
debug1: Connection established.
debug1: identity file {MY-WORKSPACE}/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file {MY-WORKSPACE}/.ssh/id_rsa-cert type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_dsa type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_dsa-cert type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_ecdsa type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8p1 Debian-7ubuntu1
debug1: match: OpenSSH_5.8p1 Debian-7ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA {SERVER_HOST_KEY}
debug1: Host 'SERVER_IP' is known and matches the ECDSA host key.
debug1: Found key in {MY-WORKSPACE}/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: password
debug1: Next authentication method: password
[email protected]_IP's password: 
debug1: Authentications that can continue: password
Permission denied, please try again.
[email protected]_IP's password: 

Şifre için normalde 'ubuntu' kullanıcısı için kullandığım aynı değeri girdim.

Sorunun nerede olduğunu ve bu sorunla ilgili bir çözüm önerisi olan herkes bana yol gösterebilir mi?

    
sordu Senthil Kumaran 02.07.2013 13:14

7 cevap

2

Sorunun nerede ve nerede olduğunu buldum.

Yeni bir kullanıcı oluşturdum (adlandırılmış: senthil) ve sadece SSH için kullandım. Ubuntu'da, yeni bir kullanıcı oluşturduğumuzda, varsayılan olarak root kullanıcısı şifresinin yeni kullanıcıya atanacağını hissediyorum. O zaman bile, yeni oluşturulan kullanıcılara sıfırlama ve yeni bir şifre atayın.

Kullanıcı şifresi sıfırlandıktan ve sshd_config dosyasında aşağıdaki değişiklikleri yaptıktan sonra, şimdi tüm sistemlerimi (ağımdan) uzak sunucuya bağlayabiliyorum.

Lütfen Dikkat: Tüm SSH kimlik doğrulamasını kapattım (RSAAuthentication, PubkeyAuthentication ve KerberosAuthentication gibi). Sadece PasswordAuthentication'ı açtım.

Teşekkürler.

    
verilen cevap Senthil Kumaran 03.07.2013 14:04
10

Hesabı kilitlediniz.

usermod(8) sayfasından:

-L, --lock
           Lock a user's password. This puts a '!' in front of the encrypted password,
           effectively disabling the password.

Şimdi shadow satırına bakın:

ubuntu:!$rWDSG...HSi1:15347:0:99999:7:::

Kilidini aç:

usermod -U ubuntu

Önemli not! Bu kullanıcı sisteme önceden yüklendiyse, bir nedenle (güvenlik nedenleriyle) kilitlenebilir, ancak sizin için normal bir Ubuntu yüklemesi olmadığı için sizin için buna karar veremem.

Yukarıdakiler sizi rahatsız ediyorsa, ayrı bir kullanıcı oluşturabilirsiniz:

sudo adduser username

ve soruları cevaplayın. Sadece iyi giriş yapabilmelisiniz. Ayrıca, sudo grubuna ekleyerek kökü haline getirebilir ( sudo kullanın):

sudo adduser username sudo

Komut satırında ubuntu kullanıcıya geçmeniz gerekiyorsa, yükseltilmiş ayrıcalıklarınızı kullanmanız gerekir, çünkü neden giriş yapamadığınızı aynı nedenden dolayı kimlik bilgileri sağlayamazsınız SSH. Şimdi, SSH'yi username olarak kullanarak giriş yapın ve bunu ubuntu olmak için çalıştırın:

sudo su -l ubuntu

Güvenlik nedeniyle, doğrudan giriş yapmak için root kullanmamayı tercih etmem.

    
verilen cevap gertvdijk 02.07.2013 13:25
6

Aynı problemim var ve bu benim için çok saatler sürüyor.

Ancak, sunucu snd istemcisinin klavye düzeni arasındaki fark nedeniyle yanlış şifre olduğunu not etmeliyim:

Sunucuda, şifre belirlediğimi düşündüm: [email protected] Ve, ben sunucu kod düzeninde @ " olduğunu not edin.

Yani doğru şifre: WEwd"ds

Böylece, şunları kontrol etmeniz gerekir:

Sunucu klavye düzeni [vs] İş istasyonu klavye düzeni

    
verilen cevap Abdennour TOUMI 12.06.2014 16:48
4

Bu soru için kesin bir cevap değil. Ama benim durumumda gereksiz çizgiler vardı. (iki kere aynı hat vardı)

PermitRootLogin yes

ve ayrıca

AllowUsers otheruser

Bu hatta 'root' kullanıcısını eklemeli veya bu satırı yorumlamalısınız.

Ve ssh service sshd restart 'ı yeniden başlat

    
verilen cevap Sadee 24.03.2017 16:25
1

Senin için bir çözümüm var Sshd_config dosyanızda, dosyanın sonuna şu satırı eklersiniz:

AllowUsers senthil

Bu satır, sunucunuzun kullanıcının adına bağlanmasına izin verir: senthil. Başka bir kullanıcı reddedilecek. Bundan sonra terminalinize terminalinize gidin, şu komutu yazın:

ssh [email protected]

Bitti! Sana iyi şanslar Daha fazla bilgi buraya gelip görebilirsin. İşte

    
verilen cevap Dang_Ho 15.09.2016 05:49
0

Çaresizlik için, /etc/hosts dosyanızı kontrol edin ve bilgisayarınızın belli bir ana bilgisayar adını gerçekte olduğundan farklı bir IP olduğunu düşünerek kandırmayacağınızdan emin olun. Bir bileşik. Ve LT

    
verilen cevap Alexander Taylor 18.10.2014 08:24
0

İzin verilen kullanıcılar için sshd erişim Listesini kontrol et (config dosyası)

  1. cat /etc/ssh/sshd_config
  2. AllowUsers

ayarlanmamalıdır, aşağıdaki örnekte gösterildiği gibi # şeklinde yorumlanmalıdır.

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       ForceCommand cvs server
Ciphers aes128-ctr,aes192-ctr,aes256-ctr
ClientAliveInterval 432000
ClientAliveCountMax 0
#AllowUsers TestUser
    
verilen cevap willer 03.06.2017 00:04

Etiketlerdeki diğer soruları oku