Giriş ekranında davul sesi nasıl devre dışı bırakılır?

110

Sistem ▸ Yönetim ▸ Giriş Ekranı ▸ Bunu kontrol etmek için giriş sesini beklerdim, ancak işaretini kaldırmak, davul çalma sesinin çalmasını engellemez.

    
sordu ændrük 05.02.2011 19:05

15 cevap

57

Başlangıç ​​sesi, Unity Greeter yapılandırmasını düzenleyerek devre dışı bırakılabilir. Bir terminalden aşağıdakileri çalıştıracaktır:

echo -e '[com.canonical.unity-greeter]\nplay-ready-sound = false' \
    | sudo tee -a /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Ubuntu 12.04 LTS çalıştırıyorsanız, bu özellik güncellemeye eklendiğinden güncellemeleri yüklediğinizden emin olun.

    
verilen cevap Andrejs Cainikovs 25.04.2016 23:34
58

Ubuntu için 12.04 +

LightDM Yolu

FluteFlute Slap olarak da bilinen LightDM Way, çıkış yapmak zorunda kalıyor ve LightDM Giriş Ekranında sesi değiştirebilir hatta sesi kapatabilirsiniz.

Oturum Açıcı Greeter'de sağ üstteki Ses düzeyini görebilirsiniz. Oturumun başladığında, ses seviyesini ayarlamak, ses seviyesini etkilemez, böylece oturumunuz başladığında sesi susturmadan Greeter'de SESSİZ yapabilirsiniz:

Ubuntu Tweak Yolu

Ubuntu Tweak yolu, Ubuntu Tweak uygulamasını indirmeyi ve ardından sesi buradan devre dışı bırakmayı gerektirir. Aşağıdaki adımları yapın ve bunu şu şekilde yapabilirsiniz:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Ubuntu Tweak 'ı açın ve Tweak Sekmesinde "Login Settings" seçeneğini seçin, Play Login Sound seçeneğini görmelisiniz. Bunu değiştirebilmek için yukarıdaki Kilit düğmesine tıklamanız gerekiyor.

Ubuntu 11.10 ve Altında

System -> Preferences -> Startup Applications

adresine git

GNOME Giriş Sesi

adını devre dışı bırak

(kutunun işaretini kaldırın ve kapat'ı tıklayın)

Ayrıca System -> Preferences -> Sound 'ye gidebilir ve tüm ses sistemini devre dışı bırakabilirsiniz (Windows sesleri, uyarılar vb. gibi)

Daha eski sürümde, Ses Tercihi bölümüne gidebilir ve her sesi ve ne yapmak istediğinizi seçebilirsiniz. 9.04 veya 9.10 civarında kaldırıldı. Geri gelse iyi olur.

    
verilen cevap Luis Alvarado 05.02.2011 19:20
54

12.04 - 16.10 (LightDM)

Geçen hafta 12.04 yükledikten sonra benim için çalışılan şey buydu.

Bu adımlar aşağıdaki gibidir: İşte :

gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Bu satırları ekleyin:

[com.canonical.unity-greeter]
play-ready-sound = false

Kaydet, ardından çalıştır:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Yeniden başlatın ve keyfini çıkarın.

    
verilen cevap K. P. MacGregor 10.09.2012 13:11
20

11.10 (LightDM ve GDM)

Hızlı çözüm:

Bir terminal açın ve komutu çalıştırın

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

Sistem hazırlığı için lightdm drum sesi aynı şekilde devre dışı bırakılabilir

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  
    
verilen cevap RobinJ 15.10.2011 13:23
11

12.04

için

Varsayılan olarak, kapalıdır. Bunu etkinleştirmek için bir terminal açın ve çalıştırın

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Ardından, X-GNOME-Autostart-enabled değerinin "true" değerini değiştirin; % Co_de%

11.10

için

X-GNOME-Autostart-enabled=true terminalini yazın ve gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop değerini true yerine false olarak değiştirin:

Şimdi başlangıç ​​uygulamalarınıza gidin ve gerekli seçeneği görüp devre dışı bırakabilirsiniz:

    
verilen cevap Bruno Pereira 15.10.2011 13:26
10

10.10 (GDM)

Giriş Ekranında bu konuda bir hata var gibi görünüyor. Resmi bir rapor bulamıyorum, ancak bu forum gönderisi bir düzeltin.

Sistem / Yönetim / Giriş Ekranına gidin. Kilidini açın, ardından işaret "Oturum açma sesini çalın".

Pencereyi kapatın, ardından tekrar uygulamaya geri dönün, kilidi açın, ardından aynı seçeneği tıklayın.

    
verilen cevap Scaine 05.02.2011 20:43
7

GDM'yi 12.04

ile kullanıyorsanız

Giriş seslerini devre dışı bırakmak için, gdm kullanıcısı için org.gnome.desktop.sound altındaki etkinlik sesleri öğesi false değerine ayarlanmalıdır.

Bunun için öncelikle kendi ana dizinine GDM sahipliğini vermeliyiz. Bir terminal açın ve şunu yazın: sudo chown -R gdm:gdm /var/lib/gdm

Çalıştırın:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

ve oturumu kapat (veya yeniden başlat).

12.04

ile LightDM kullanıyorsanız

Bir terminali Ctrl + Alt + T ile açın ve aşağıdakini yazın / yapıştırın, tek seferde bir satır:

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter play-ready-sound false
exit

Bunun anlamı giriş ekranı / masaüstü yöneticisi kullanıcısı (lightdm) için play-ready-sound ayarını devre dışı bırakır.

    
verilen cevap ish 10.09.2012 12:15
5

11.10 (LightDM ve GDM)

Başlangıç ​​sesini kaldırmak için:

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

Başlangıç ​​sesini etkinleştirmek için

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

Giriş Sesini kaldırmak için (Giriş yaptıktan sonra):

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

Yeniden etkinleştirmek için:

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
    
verilen cevap Vibhav Pant 07.03.2012 09:03
3

11.10 (LightDM ve GDM)

Bu senin için çalışmalı.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Ardından NoDisplay = false, ect.

'i değiştirin.

veya kaldırmak için:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg
    
verilen cevap Ringtail 07.03.2012 09:02
3

11.10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false
    
verilen cevap blueyed 30.09.2011 09:13
1

12.10 (GDM)

Yukarıdakilerin hiçbiri gdm ile çalışmıyor. Sistem hazır sesini (bongos) devre dışı bırakırsam, yine de kısa bir davul sesi çıkarır (bir vuruş).

Bunu devre dışı bırakma yolu:

  • Önyükleme, gdm'ye girin.
  • Konsola geçin ( Ctrl + Alt + F1 )
  • Giriş
  • girin:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Gdm'ye geri dön ( Ctrl + Alt + F8 )

  • Mikserde sesi devre dışı bırakın. Bunu "Oynatma" ve "Çıkış Cihazları" nda kapattım.
  • Karıştırıcıyı kapatın, yapılandırma dosyasını yazmakla ilgili bir hatayla karşılaşabilirsiniz, bu zararsızdır.
  • Konsola geri dönün ve

    girin
    sudo service gdm restart
    
    Test etmek için

    ve çıkış yapmak için exit .

verilen cevap jdm 17.07.2012 18:02
1

11.04 ve önceki (GDM)

Bu komutu bir terminalde mi çalıştırmalısınız?

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

    
verilen cevap Jorge Castro 11.09.2012 05:49
1

12.10 (LightDM)

Aynı komutu Jorge Castro verdi , yalnızca gdm lightdm ile değiştirilir:

sudo -u lightdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
    
verilen cevap C Schilder 27.06.2012 09:51
1

En kolay yol, sadece selamlamada sesi susturmaktır. Sadece sesi tıklayın ve "sustur" u tıklayın.

Bu, yalnızca selamlayıcıda sesi susturur.

    
verilen cevap Pilot6 15.06.2015 12:48
0

12.04 (LightDM)

LightDM bongo sesi 12.04'te herhangi bir GUI seçeneği ile devre dışı bırakılamaz ve burada bir hata raporu vardır:

Yukarıdaki komut satırı yöntemleri onu devre dışı bırakabilir.

Giriş yaptıktan sonraki ses, yukarıdaki cevaplarla kolayca devre dışı bırakılabilir.

    
verilen cevap Eric Nemchik 07.04.2012 04:04

Etiketlerdeki diğer soruları oku