“ctrl + boşluk”, bazı giriş yöntemlerini çağırmak zorunda kalmıştır ve Emacs veya Eclipse otomatik tamamlamada çalışmaz

81

Emacs'te terminalde çalışır, ctrl + boşluk , bölgeyi seçmek için standart bir kısayol tuşudır. Fakat Ubuntu 12.04 kapsamında, İngilizce olmayan bir dil için bazı giriş yöntemlerini kullanacaktır. Sadece Emacs için rezerve edebilir miyim diye merak ediyordum?

System Settings -> Keyboard -> Shortcuts altında, ctrl + boşluğu 'nun ne olduğunu göremedim. Garip.

Diğer programlar, özellikle Eclipse'de otomatik tamamlama, ctrl + boşluk işlemiyle ilgili bir sorun var gibi görünüyor.

    
sordu Tim 16.01.2013 00:55

7 cevap

119

Bu, giriş düzenleyiciyi etkinleştirmek / devre dışı bırakmak için varsayılan olarak Ctrl + Boşluk 'nı kullanan İbus çalışmasına sahip olduğunuza benziyor.

İbus Tercihleri'nde kendisine atanan kısayol tuşunu değiştirebilirsiniz.

Ibus, menü çubuğunda çalışıyorsa menüden Tercih seçeneğini seçmek için sağ tıklayabilirsiniz. Ibus, menü çubuğunda çalışmıyorsa, Klavye Giriş Yöntemleri 'ni çalıştırarak veya ibus-setup ile terminalden Tercihler iletişim kutusunu Dash'tan başlatabilirsiniz.

14.04 için güncelle

ibus-setup artık 14.04 için mevcut değil. Önceki ibus-setup 'sındaki işlevler Sistem Ayarları & gt; & gt; Metin Girişi .

Girdi anahtarlama artık varsayılan olarak Süper + Boşluk olarak ayarlanmıştır, ancak Ibus yine de Control + Uzayından odağı çalabilir. keybinding ve diğer sistem sorunlarına, özellikle Eclipse'deki otomatik tamamlamaya neden olur.

Ibus giriş anahtarının yeni Metin Giriş ayarlarına entegrasyonu hala devam eden bir çalışmadır ve bu, eski ayarların hala sahnelerin gerisinde kalması nedeniyle soruna neden olmaktadır.

12.04'ten yeni sürüme geçtiyseniz, ibus-settings 'si hala mevcut olmalıdır.

14.04'te, ayarları doğrudan dconf-editor olarak düzenleyebilirsiniz.

Yüklü değilse:

sudo apt install dconf-editor

Sonra Masaüstü & gt; & gt; ibus & gt; & gt; genel & gt; & gt; kısayol tuşu . % Co_de% ve trigger ayarı yine de "control + space" gösterecektir. Bu ayarları düzenleyin, boş köşeli parantezleri triggers içinde [] bırakmak için dikkatli olun.

    
verilen cevap chaskes 16.01.2013 01:59
10

Komut satırını kullanarak IBUS tetikleyiciyi devre dışı bırakın:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

Ya da eğer işe yaramazsa, ilki bir hata oluşturuyorsa deneyin:

gsettings set org.freedesktop.ibus.general.hotkey triggers []
    
verilen cevap aba 24.06.2014 09:46
4

ibus bana baş ağrısından başka bir şey yapmıyor. Ayarları değiştirmeye çalıştığım her zaman, yeniden başlattığımda Ctrl + Space geri gelir. İşte benim çözümüm:

sudo apt-get purge ibus
sudo killall ibus

Artık her şey Ubuntu'nun bir sonraki aptalca kararına kadar işe yarıyor. Belki de 'o' harfi bilgisayarı kapatacak mı?

    
verilen cevap Eyal 11.02.2015 13:47
2

Ubuntu 14.04'e yükselttikten sonra, aynı problemi yaşadım. Ne yaptım. Ibus tercihlerinde: % Co_de%.
Bir seçenek var: System > Preferences > Keyboard Input Methods ctrl + boşluk olarak ayarlandı, bunu kaldırdım ve sonra hepsi tekrar çalışmaya başladı.

    
verilen cevap wmlynarski 24.07.2014 11:04
1

Ubuntu Studio 14.04 (XFCE) burada. Otomatik Tamamlama ile ilgili sorun yaşamadım ( Ctrl + Space ), ancak Kopyalama Satırı ( Ctrl + Alt + Down ).

Bu benim için çalıştı:

  • Windows Yöneticisi'ni aç: xfwm4-settings
  • Klavye sekmesine git
  • Çakışan Eylem’e ilerleyin
  • Temizle düğmesine basın veya eylemi farklı kısayollara değiştirin
verilen cevap luboskrnac 04.04.2015 13:34
0

LXDE ile Ubuntu 14.04 GNOME'um var. Görünüşe göre bu masaüstünde ibus-kurulum var. Yani, benim için, ibus ayarını değiştirmek doğru düzeltmekti. Belki de ibus-setup uygulamasıyla uzaklaşan bir birlik vardı.

    
verilen cevap JamesH 28.12.2014 05:28
0

dconf-editor değişikliği benim için yeterli değildi. Mozc (Japonca) giriş kaynağım kurulu.

Ubuntu 16.04'te ayrıca şunları da yapmalıydım:

  1. Sistem Ayarları - & gt; Metin Girişi
  2. Vurgulamak için Mozc’ı tıklayın
  3. Aşağıdaki anahtar / tornavida simgesini tıklayın
  4. Genel Yapılandırma sekmesi
  5. Burada ilk ayar olan "Tetik Giriş Yöntemi", CTRL_SPACE idi. Tıkladım ve ardından tuş kilidini kaldırmak için Kaçış 'a basın.
verilen cevap TalkLittle 08.09.2016 19:18

Etiketlerdeki diğer soruları oku