Çift Ekran kurulumunda ikinci ikinci Unity Launcher'ı nasıl kaldırabilirim?

146

İkili ekran ekranımda, sol taraftaki ekranda ve ayrıca sağdaki ekranda bir Unity Launcher var. Her ikisi de mükemmel çalışıyor.

Ancak, bu ikinci başlatıcının sağ ekranımda görünmesini istemiyorum. Bunu nasıl kaldırabilirim? Önemliyse, TwinView kurulumu ile NVIDIA sürücülerini kullanıyorum.

    
sordu Eugene van der Merwe 25.02.2012 09:46

6 cevap

216

Artık yapabilirsiniz.

Ekran tercihlerini açın ve daha sonra başlatıcıyı bir ekranda veya tümünü gösterme arasında seçim yapabilirsiniz.

Bu diyalog ayrıca ekranlar arasında yapışkan kenarların (yani, fare yavaşlatması) açılmasına veya kapatılmasına da izin verir.

    
verilen cevap jrg 31.03.2012 19:46
33

Yavaşlama, otomatik gizlemeye ayarlandığında başlatıcının kullanılmasını mümkün kılan bir özelliktir. Başlatıcı her zaman görünür olacak şekilde ayarlandığında kullanılan bir hata olduğunu düşünüyorum. Hataların yapıldığı Launchpad.net'te rapor ettim ve sizi etkileyecek şekilde ayarlamak isteyebilirsiniz. Burada bulabilirsiniz: İşte

Bu arada, gconf editöründe /apps/compiz-1/plugins/unityshell/screen0/options/overcome_pressure ve /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity değerini kullanarak kendiniz yapılandırabilirsiniz

Ayrıca, bu parametreleri CCSM'de (Compiz Config Settings Manager) Unity Plugin, Experimental sekmesinde

de yapılandırabilirsiniz.     
verilen cevap Jo-Erlend Schinstad 03.03.2012 21:44
8

Gconf editöründe, başlatıcıyı yalnızca birincil masaüstünüze ayarlamanıza izin verecek bir ayar buldum: /apps/compiz-1/plugins/unityshell/screen0/options/num_launchers . Bunu 1 olarak ayarlarsanız, Unity başlatıcısı yalnızca birincil masaüstünde görüntülenir. Onu 0 olarak ayarlarsanız, başlatıcı tüm masaüstlerinde kullanılabilir.

Bu ayara ek olarak, aynı zamanda üstesinden gelen basıncı ( /apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1 ) ve durma hızını da ( /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20 ) ayarlıyorum.

    
verilen cevap Todd Wallentine 17.05.2012 15:27
4

Disper kullanarak çözdüm. Bir terminal girin:

sudo apt-get install disper

Sorunu Paŭlo Ebermann veya nvidia-settings tarafından önerilen yöntemle çözdikten sonra veya sizin için ne işe yararsa, bir terminale yazın:

disper --export < /path-to-my-file/my-disper-file.metamode

my-file.metamode şöyledir:

backend: nvidia
associated displays: DFP-0, DFP-1
metamode: DFP-0: 1366x768 @1366x768 +1920+312, DFP-1: 1920x1080 @1920x1080 +0+0
scaling: stretched, stretched
xinerama info order: DFP-1, DFP-0

Üçüncü sıra, farklı yüksekliklerde iki ekranın özel konumlandırmasını dikkate alır. Durumunuz daha basit olabilir. Yapılandırmanıza uyan dosyayı oluşturmayı deneyebilirsiniz (diğer yöntemleri kullanmadan + disper --export). Önemli olan, ikinci ve son satırlardaki ekranların sırasıdır.

Komut dosyasını kullanabilir ve başlangıçta çalışmasını sağlayabilirsiniz:

#!/bin/sh
#Auto switch single/extend display with disper on Multiple Monitor.
lines=$(disper -l | wc -l)
display_count=$((lines / 2))
if [ $display_count -eq "1" ]; then
   disper -s
else
   disper --import < /path-to-my-file/my-disper-file.metamode
fi

Nvidia grafik kartımla çalıştı (hem hassas hem de quantal).

Umarım yardımcı olur.

    
verilen cevap cesare sodi 26.10.2012 12:14
3

Birleştirilmiş ayarları yukarıdan denedim:

/apps/compiz-1/plugins/unityshell/screen0/options/num_launchers=1
/apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1
/apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20

Bu benim için çoğunlukla başarılı oldu. Bir başlatıcı sadece birincil ekranda görünür ve fare gereksiz bir tereddüt etmeden bir ekrandan diğerine geçer. Ancak, kalan başlatıcının süper anahtarı kullanmadan ortaya çıkmayacağını buldum. Bu, aşağıdakileri ayarlayarak düzeltilebilir:

/apps/compiz-1/plugins/unityshell/screen0/options/reveal_pressure=1

BTW, bu NVidia sürücüleri ile.

    
verilen cevap David Sowerby 15.07.2012 11:59
0

Sadece /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity 'sının 1 ' sini değiştirmek benim için sorunu çözdü ... İkinci ekran çubuğunu kaldırmak istemedim, sadece bir ekrandan diğerine geçerken aradaki duraklamayı beğenmedim.

    
verilen cevap brbcoding 03.08.2012 22:17

Etiketlerdeki diğer soruları oku