Hangi Debian sürümü farklı Ubuntu sürümleri temel alır?

71

Ubuntu 10.04, 10.10 ve 12.10 için özelleştirilmiş bazı yazılım paketlerim var, ama şimdi bunları Debian Squeeze'de yüklemem gerekiyor. Belirli Ubuntu ve Debian sürümleri arasında bir haritalama için Google’a gidemedim. Birisi yardım edebilir mi?

Özellikle hangi Ubuntu sürümünün Debian Squeeze ile uyumlu olduğunu bilmek istiyorum.

    
sordu xkcd 09.04.2014 16:28

2 cevap

139

Ubuntu sürümünüzün dosyada bulunduğu Debian sürümünü bulabilirsiniz: /etc/debian_version

10.04'ten 17.04'e kadar:

   Ubuntu      |       Debian  
18.04  bionic     buster  / sid   - 10
17.10  artful     stretch / sid   - 9
17.04  zesty      stretch / sid
16.10  yakkety    stretch / sid
16.04  xenial     stretch / sid
15.10  wily       jessie  / sid   - 8
15.04  vivid      jessie  / sid
14.10  utopic     jessie  / sid
14.04  trusty     jessie  / sid
13.10  saucy      wheezy  / sid   - 7
13.04  raring     wheezy  / sid
12.10  quantal    wheezy  / sid
12.04  precise    wheezy  / sid
11.10  oneiric    wheezy  / sid
11.04  natty      squeeze / sid   - 6
10.10  maverick   squeeze / sid
10.04  lucid      squeeze / sid

sid, Debian’ın geliştirme dağılımıdır. (sid - testing - stable)

Dosyanın içeriğini, % paketinin kaynaklarını görüntüleyerek tüm sistemi kurmadan öğrenebilirsiniz. Launchpad'de% co_de .

    
verilen cevap Jacob Vlijm 09.04.2014 16:43
5

Ne yazık ki, Jacob'un cevabında kaba bir fikir veren doğrudan haritalama / etc / debian_version yoktur, ancak sadece bir paketi yansıtır ve söz konusu paket Ubuntu'da yerel olarak değiştirilen bir pakettir ve bu yüzden otomatik olarak çekilmez. Debian.

Özellikle Ubuntu, çoğunlukla libc6 gibi çekirdek paketlerde Debian’ın önünde. Ubuntu üzerine kurulu bir paketin Debian'ın güncel bir sürümünde kurulmaya çalışılması büyük olasılıkla, libc6'daki sürüm hatalarıyla sonuçlanacaktır.

İşte 'e göre Debian sıkıştırması libc6 vardı 2.11. İşte ubuntu 10.04 'e göre de lucid libc6 2.11 . Yani 10.4 lucid için paketler IMO'dur ve Squeeze üzerinde çalışmaktadır.

Programınızın ihtiyaç duyduğu diğer kitaplıklara bağlı olarak, Debian sıkıştırması için belirli bir yapının gerekli olduğunu da görebilirsiniz.

    
verilen cevap Peter Green 20.04.2016 17:42

Etiketlerdeki diğer soruları oku