Güncelleme yöneticisi ile güncelleme yaparken “Güvenilmeyen Paketlerin Kurulmasını Gerektirin”

65

Bu hatayı düzeltmedi. Peki, GUI güncellememi nasıl düzeltebilirim?

Her yazılım için, Ubuntu Software Center yazılımını yüklerken aynı hatayı aldığım için onu komut satırından yüklemem gerekiyor.

    
sordu One Zero 29.03.2012 13:55

7 cevap

63
  1. Bir terminalde yaz: sudo apt-get update && sudo apt-get upgrade veya Güncelleme Yöneticisi ayarlarını düzenleyin (daha önce Güncelleme Yöneticisini yapılandırdıysanız bunu deneyin).

  2. Güncelleme Yöneticisi'ni başlatın ve tekrar deneyin.

Güncelleştirmeyi bir uçbirim aracılığıyla çalıştırmak güvenilmeyen paketlere izin verilip verilmeyeceğine karar verir.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Paket kaynağına güveniyorsanız, y yazın.

    
verilen cevap Zlatan 29.03.2012 19:14
43

Bu, bazı GPG anahtarlarının eksik olması nedeniyle gerçekleşir. Bunu düzeltmek için, bir terminal açın ve aşağıdaki komutları çalıştırın:

sudo apt-get update

Bazı genel anahtarın mevcut olmadığını belirten bir hata alırsınız. Anahtar dizesini not edin (NO_PUBKEY'den sonra; örn .: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

XXXXX anahtar dizgisiyle değiştirin

ör .: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

ör .: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Şimdi sisteminizi tekrar güncellemeyi deneyin.

Benzer bir gönderi: "Güvenilmeyen güncellemeleri yüklemesi gerekiyor" Güncelleme Yöneticisi'nde hata

Bunun yardımcı olacağını umuyorum.

    
verilen cevap aneeshep 01.12.2010 10:05
13

Komut satırı üzerinden yükleyebilirsiniz: sudo apt-get install --allow-unauthenticated exiv2 .

Repo’yu kalıcı olarak "güvene" almak için şunu uygulayın: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update . Kullandığınız PPA'nın olduğuna inanıyorum.

    
verilen cevap evgeny 01.12.2010 10:12
5

Sorunuza yanıt olarak, GUI güncellemesini (yani Güncelleme Yöneticisi) "düzeltmeniz" için yapamazsınız , çünkü bu uygulamanın şu anda güvenilir olmayan paketleri yükleme kapasitesine sahip olmadığı açıktır. Güvenilmeyen paketleri kurmak isterseniz, komut satırında yapmanız gerekir.

Ancak, Güncelleme Yöneticisi'nin bu hatayı bildirmesini engellemenin iki yolu vardır: Güvenilmeyen yazılımı sisteminizden kaldırın VEYA güven söz konusu depoyu diğer tarafın yanıtında belirtildiği gibi kaldırın. soru ( Güncellemeler "güvenilmeyen paketler" nedeniyle yüklenmiyor .

İlk adım, hangi deponun soruna neden olduğunu bulmaktır. Bunu, komut satırında apt-cache policy ambiance-colors yazarak bulabilirsiniz.

Ancak, hızlı bir google, ambiance-colors ve radiance-colors 'si ppa:ravefinity-project ' sindendir. Bu nedenle, sorununuzu

yazarak düzeltmeniz gerekir.
sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

İşte 'den alınmıştır

    
verilen cevap stackex humanoid 10.06.2012 22:06
1

bunun neden böyle söylediği, yüklemeye çalıştığınız paketler üçüncü taraf yazılımıdır. Bunları yüklemek isterseniz, güncelleme yöneticisi ayarlarında diğer yazılım Sekmesindeki Canonical Check kutusunu etkinleştirin ve sonra tekrar deneyin. yükleme

Bunun yardımcı olacağını umuyorum.

    
verilen cevap Ten-Coin 29.03.2012 19:21
1

Aynı problemim vardı. Benim için bu komut işe yaradı:

sudo apt-get update --fix-missing

Bunun diğer çözümlere kıyasla avantajı sadeliğidir. GUI'yi kullanmaya devam edebilir ve hangi deponun bozulduğunu öğrenmeye gerek yoktur. Bir yorumda burada çözüm buldum. Ubuntu'yu açıklamaya yetecek kadar bilmiyorum, ama sanırım tüm reposların çalışması için gerekli anahtarları alıyor.

    
verilen cevap smoortema 20.09.2013 10:58
0

Sorunuz açık değil: hatayı düzelterek "GUI güncellemenizi düzeltin". Diğer soru size ne yapacağınızı gösterir.

Güncellemeleriniz güvenilmeyen bir kaynağa güveniyorsa, seçiminizi kaldırabilir veya belirli bir kaynağa kalıcı olarak güvenmek için komut satırını kullanabilir ve kullanabilirsiniz. Bunlardan birini yaptıktan sonra mesaj açılmayacak. Eğer ikincisini yaparsanız, o zaman söz konusu kaynak için mesaj tekrar görünmeyecektir.

    
verilen cevap Mei 29.03.2012 19:04

Etiketlerdeki diğer soruları oku