Ubuntu'da devam edildikten sonra kablosuz ağ çalışmıyor 14.04

78

[Güncelleme]:
Aynı problem Kubuntu'da da var ve aynı şekilde çözüldü. [Çözüldü]:
Aşağıdaki komutu nmcli nm uygulayarak aşağıdakileri aldım:

Askıya almadan önce

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled  

devletin bağlı olduğunu ve geri kalanların etkin ve çalışır durumda olduğunu görebildiğiniz gibi

Askıya alındıktan sonra

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         asleep          enabled         enabled    enabled         disabled

devletin uykuda olduğunu görebildiğimiz gibi, sevgili ağ yöneticimiz hala uyuşmuyor, bu yüzden de yanlış komut satırını kullanmak için: % sudo nmcli nm sleep false
Bu, ağ yöneticisine cehennemi uyandırmasını söyler. Bu permenantı yapmak için:
Aşağıdakileri içeren /etc/pm/sleep.d komut dosyası oluşturun (ve betiği yürütülebilir olarak işaretlemeyi unutmayın):

#!/bin/sh

case "" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

bu

Orijinal sorun:

Ubuntu 14.04'ü yeni indirdim ve dizüstü bilgisayarıma yükledim: Intel P8400 Core2Duo x64 işlemci ile ASUS X61SL. Kapağı kapattığımda, sistem askıya alınır, ancak kapağı tekrar açıp tekrar açtığımda, kablosuz ağ etkinleştirilmez (ağ iletişimi bir bütün olarak devre dışı bırakılır) ve "Ağ Etkinleştir" seçeneğini işaretlediğimde hiçbir şey olmuyor. Kablosuz adaptörüm hakkında bilgiler:

$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)  

Bu sorun Ubuntu 13.04, Linux Mint Debian Edition veya Debian 7 wheezy (GNOME veya KDE) içinde mevcut değildi.

Düzenleme: aşağıdaki sonuçlarla birkaç test:
Sorun benim kablosuz ve kablolu ağımı etkiler.
Not: Önyüklemek için pci=nomsi satırını gruba eklemem gerekiyor. Manuel olarak çıkış yaptıktan sonra askıya alın ve ardından devam ettirin, sonra her şey iyi çalışır. Doğrudan oturum açarken askıya alındığında sorun olur.
Kilitleme ve askıya alma, doğrudan askıya alma ile aynı soruna neden olur.
Ayrıca bu problem appearnlty çıkış fonksiyonunu etkiler: Eğer birleşme panelindeki kullanıcı menüsünden çıkış yapmayı seçtiyseniz, o zaman çıkış yapamazsınız, fakat eğer% co_de komut satırını kullanırsanız, çıkış yapabilirsiniz. Şimdi gnome-session-quit --logout çıkışı ile:
Normal (tam işlevsel ağ):

  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A ip=6.6.6.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Yeniden başladıktan sonra ("/etc/pm/config.d" "unload_modules" içermiyor):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

unload_modules dosyasını burada , çıkış yaptıktan, askıya aldığınızda, devam ettikten sonra ağ oturumlarına giriş yaptıktan sonra kablosuz ağa bağlanamıyorum.
Yine lshw -C network sonucu Devam ettikten sonra ("/etc/pm/config.d" "unload_modules" içerir):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

'unload_modules' içeriği:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"
SUSPEND_MODULES="$SUSPEND_MODULES sis190"

'ath9k' benim kablosuz modülüm ve 'sis190' benim Ethernet modülüm.

    
sordu Ossama Nasser 22.04.2014 15:13

5 cevap

27

Yukarıdaki cevaplar 14.10'da benim için çalışmadı. Biraz deneme-yanılmadan sonra, bununla sona erdi,

#!/bin/sh

case "" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on ;;
esac

Bunu /etc/pm/sleep.d/10_resume_wifi dizinine koy -
Uygulamayı sudo chmod 755 /etc/pm/sleep.d/10_resume_wifi yapın ve sorun hemen düzeltilmelidir.

    
verilen cevap Owais Lone 13.04.2015 22:03
21

Bir çözüm buldum, ancak bu sadece ağ yöneticinizi yeniden başlatmak içindir.

sudo service network-manager restart

Kalıcı çözüm değil.

    
verilen cevap hmjha 20.03.2016 11:40
4

Sonunda benim için çalışan komut dosyası:

$ cat /etc/pm/sleep.d/10_resume_wifi 
#!/bin/sh

case "" in
  resume|thaw) nmcli nm sleep false ;;
esac

$ ll /etc/pm/sleep.d/10_resume_wifi
-rwxr-xr-x 1 root root 70 mars  31 09:09 /etc/pm/sleep.d/10_resume_wifi

Diğer cevapta yazım hataları var (bildiğim kadarıyla düzeltilebilirler), ama yine de benim için hiç çalışmadım.

    
verilen cevap Augustin Riedinger 31.03.2015 09:21
0

Bu benim için Dell Precision dizüstü bilgisayarında Ubuntu 14.04 üzerinde çalıştı.

Bir terminalde şunu girin:

sudo nano /etc/pm/sleep.d/10_resume_wifi

Sonra yapıştırın (ctrl + v):

#!/bin/sh
case "" in
resume|thaw)
    nmcli nm wifi on
    ;;
esac

Ardından, betiği çalıştırılabilir yapın:

sudo chmod +x /etc/pm/sleep.d/10_resume_wifi

Askıya almayı deneyin ve wifi'yi görmek için uyandırın !!

    
verilen cevap FizxMike 15.05.2016 02:05
-3

Bu kişinin kate'ye girmesi gibi başka bir betik yapmaya çalıştın mı:

#/bin/sh

    case ![1] in
        ./bin/sh
        network="true"
        nmcli nm -c sleep=false -network
    endasc

ve / etc / network dizininde jsin7 dosyası olarak kaydedin ve buna network.d adını verin.

    
verilen cevap Michael 30.05.2014 11:45

Etiketlerdeki diğer soruları oku